Click or drag to resize

GetBaseClass Class

Base class for GetObject, GetPoint, GetSphere, etc. You will never directly create a GetBaseClass but you will use its member functions after calling GetObject.Gets(), GetPoint.Get(), and so on. Provides tools to set command prompt, set command options, and specify if the "get" can optionally accept numbers, nothing (pressing enter), and undo.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetBaseClass
    More...

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class GetBaseClass : IDisposable

The GetBaseClass type exposes the following members.

Constructors
  NameDescription
Protected methodGetBaseClass
Initializes a new instance of the GetBaseClass class
Top
Methods
  NameDescription
Public methodAcceptColor
If you want to allow the user to be able to type in a color r,g,b or name during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptColor(true) before calling GetPoint()/GetObject(). If the user chooses to type in a color, then the result code GetResult.Color is returned and you can use RhinoGet.Color() to get the value of the color. If the get accepts points, then the user will not be able to type in r,g,b colors but will be able to type color names.
Public methodAcceptCustomMessage
Public methodAcceptEnterWhenDone
There are instances of RhinoGet that prompt with "Press Enter when Done." yet do not call AcceptNothing(). On the Mac, these instances need an additional call to AcceptEnterWhenDone() so the GetPointOptions dialog can correctly enable the Done button.
Public methodCode exampleAcceptNothing
If you want to allow the user to be able to press enter in order to skip selecting a something in GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptNothing( true ) beforehand.
Public methodAcceptNumber
If you want to allow the user to be able to type in a number during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptNumber() beforehand. If the user chooses to type in a number, then the result code GetResult.Number is returned and you can use RhinoGet.Number() to get the value of the number. If you are using GetPoint and you want "0" to return (0,0,0) instead of the number zero, then set acceptZero = false.
Public methodAcceptPoint
If you want to allow the user to be able to type in a point then call AcceptPoint(true) before calling GetPoint()/GetObject(). If the user chooses to type in a number, then the result code GetResult.Point is returned and you can use RhinoGet.Point() to get the value of the point.
Public methodAcceptString
If you want to allow the user to be able to type in a string during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptString(true) before calling GetPoint()/GetObject(). If the user chooses to type in a string, then the result code GetResult.String is returned and you can use RhinoGet.String() to get the value of the string.
Public methodAcceptUndo
If you want to allow the user to have an 'undo' option in GetPoint.Get(), GetObject.GetObjects(), etc., then call AcceptUndo(true) beforehand.
Public methodAddOption(LocalizeStringPair)
Adds a command line option.
Public methodCode exampleAddOption(String)
Adds a command line option.
Public methodAddOption(LocalizeStringPair, LocalizeStringPair)
Adds a command line option.
Public methodAddOption(String, String)
Adds a command line option.
Public methodAddOption(LocalizeStringPair, LocalizeStringPair, Boolean)
Adds a command line option.
Public methodAddOption(String, String, Boolean)
Adds a command line option.
Public methodAddOptionColor(LocalizeStringPair, OptionColor)
Add a command line option to get colors and automatically save the value.
Public methodAddOptionColor(String, OptionColor)
Add a command line option to get colors and automatically save the value.
Public methodAddOptionColor(LocalizeStringPair, OptionColor, String)
Add a command line option to get colors and automatically save the value.
Public methodAddOptionColor(String, OptionColor, String)
Add a command line option to get colors and automatically save the value.
Public methodCode exampleAddOptionDouble(LocalizeStringPair, OptionDouble)
Adds a command line option to get numbers and automatically save the value.
Public methodCode exampleAddOptionDouble(String, OptionDouble)
Adds a command line option to get numbers and automatically save the value.
Public methodAddOptionDouble(LocalizeStringPair, OptionDouble, String)
Adds a command line option to get numbers and automatically saves the value.
Public methodAddOptionDouble(String, OptionDouble, String)
Adds a command line option to get numbers and automatically save the value.
Public methodAddOptionEnumListT(String, T)
Adds a choice of enumerated values as list option
Public methodAddOptionEnumListT(String, T, T)
Adds a choice of enumerated values as list option. Allows to include only some enumerated values.
Public methodAddOptionEnumSelectionListT
Adds a list of enumerated values as option list. Use enumSelection[go.Option.CurrentListOptionIndex] to retrieve selection.
Public methodCode exampleAddOptionInteger(LocalizeStringPair, OptionInteger)
Adds a command line option to get integers and automatically save the value.
Public methodCode exampleAddOptionInteger(String, OptionInteger)
Adds a command line option to get integers and automatically save the value.
Public methodAddOptionInteger(LocalizeStringPair, OptionInteger, String)
Adds a command line option to get integers and automatically save the value.
Public methodAddOptionInteger(String, OptionInteger, String)
Adds a command line option to get integers and automatically save the value.
Public methodCode exampleAddOptionList(LocalizeStringPair, IEnumerableLocalizeStringPair, Int32)
Adds a command line list option.
Public methodCode exampleAddOptionList(String, IEnumerableString, Int32)
Adds a command line list option.
Public methodCode exampleAddOptionToggle(LocalizeStringPair, OptionToggle)
Adds a command line option to toggle a setting.
Public methodCode exampleAddOptionToggle(String, OptionToggle)
Adds a command line option to toggle a setting.
Public methodCode exampleClearCommandOptions
Clear all command options.
Public methodClearDefault
Clears any defaults set using SetDefaultPoint, SetDefaultNumber, SetDefaultString, or SetCommandPromptDefault.
Public methodColor
Gets a color if Get*() returns GetResult.Color.
Public methodCode exampleCommandResult
Helper method for getting command result value from getter results.
Public methodCustomMessage
Public methodDispose
Releases all resources used by the GetBaseClass
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the GetBaseClass and optionally releases the managed resources
Public methodEnableTransparentCommands
Control the availability of transparent commands during the get.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetSelectedEnumValueT
Returns the selected enumerated value. Use this in combination with AddOptionEnumListT(String, T).

This must be called directly after having called a Get method, and having obtained a Option value.

Public methodGetSelectedEnumValueFromSelectionListT
Public methodGotDefault
Returns true if user pressed Enter to accept a default point, number, or string set using SetDefaultPoint, SetDefaultNumber, or SetDefaultString.
Public methodLine2d
Returns two points defining the location in the view window of the 2d line selected in GetPoint::Get2dLine().

(0,0) = upper left corner of window.

Public methodCode exampleNumber
Gets a number if GetPoint.Get(), GetObject.GetObjects(), etc., returns GetResult.Number.
Public methodOption
Public methodOptionIndex
Public methodPickRectangle
If the get was a GetObjects() and the mouse was used to select the objects, then the returned rectangle has left < right and top < bottom. This rectangle is the Windows GDI screen coordinates of the picking rectangle. RhinoViewport.GetPickXform( pick_rect, pick_xform ) will calculate the picking transformation that was used. In all other cases, left=right=top=bottom=0;
Public methodCode examplePoint
Gets a point if Get*() returns GetResult.Point.
Public methodPoint2d
Returns location in view of point in selected in GetPoint::Get() or GetPoint::Get2dPoint(). (0,0) = upper left corner of window.
Public methodStatic memberPostCustomMessage
Public methodRectangle2d
Returns the location in the view of the 2d rectangle selected in GetPoint::Get2dRectangle(). rect.left < rect.right and rect.top < rect.bottom (0,0) = upper left corner of window.
Public methodResult
Returns result of the Get*() call.
Public methodCode exampleSetCommandPrompt
Sets prompt message that appears in the command prompt window.
Public methodCode exampleSetCommandPromptDefault
Sets message that describes what default value will be used if the user presses enter. This description appears in angle brackets <> in the command prompt window. You do not need to provide a default value description unless you explicitly enable AcceptNothing.
Public methodSetDefaultColor
Sets a color as default value that will be returned if the user presses ENTER key during the get.
Public methodSetDefaultInteger
Sets a number as default value that will be returned if the user presses ENTER key during the get.
Public methodSetDefaultNumber
Sets a number as default value that will be returned if the user presses ENTER key during the get.
Public methodSetDefaultPoint
Sets a point as default value that will be returned if the user presses the ENTER key during the get.
Public methodCode exampleSetDefaultString
Sets a string as default value that will be returned if the user presses ENTER key during the get.
Public methodSetOptionVaries
Sets a command line option value to print "Varies" instead of the regular value.
Public methodSetWaitDuration
Sets the wait duration (in milliseconds) of the getter. If the duration passes without the user making a decision, the GetResult.Timeout code is returned.
Public methodCode exampleStringResult
Gets a string if GetPoint.Get(), GetObject.GetObjects(), etc., returns GetResult.String.
Public methodVector
Gets a direction if Get*() returns GetResult.Point (Set by some digitizers, but in general it's (0,0,0).
Public methodCode exampleView
Gets a view the user clicked in during GetPoint.Get(), GetObject.GetObjects(), etc.
Top
See Also
Inheritance Hierarchy