Click or drag to resize

GetBaseClassAddOptionEnumSelectionListT Method

Adds a list of enumerated values as option list. Use enumSelection[go.Option.CurrentListOptionIndex] to retrieve selection.

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public int AddOptionEnumSelectionList<T>(
	string englishOptionName,
	IEnumerable<T> enumSelection,
	int listCurrentIndex
)
where T : struct, new(), IConvertible

Parameters

englishOptionName
Type: SystemString

[Missing <param name="englishOptionName"/> documentation for "M:Rhino.Input.Custom.GetBaseClass.AddOptionEnumSelectionList``1(System.String,System.Collections.Generic.IEnumerable{``0},System.Int32)"]

enumSelection
Type: System.Collections.GenericIEnumerableT

[Missing <param name="enumSelection"/> documentation for "M:Rhino.Input.Custom.GetBaseClass.AddOptionEnumSelectionList``1(System.String,System.Collections.Generic.IEnumerable{``0},System.Int32)"]

listCurrentIndex
Type: SystemInt32

[Missing <param name="listCurrentIndex"/> documentation for "M:Rhino.Input.Custom.GetBaseClass.AddOptionEnumSelectionList``1(System.String,System.Collections.Generic.IEnumerable{``0},System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.Input.Custom.GetBaseClass.AddOptionEnumSelectionList``1(System.String,System.Collections.Generic.IEnumerable{``0},System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Rhino.Input.Custom.GetBaseClass.AddOptionEnumSelectionList``1(System.String,System.Collections.Generic.IEnumerable{``0},System.Int32)"]

See Also