Click or drag to resize

GetObject Class

The GetObject class is the tool commands use to interactively select objects.
Inheritance Hierarchy

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetObject : GetBaseClass

The GetObject type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleGetObject
Initializes a new instance of the GetObject class
Top
Properties
  NameDescription
Public propertyAlreadySelectedObjectSelect
Allow selecting objects that are already selected. By default, GetObjects() disallows selection of objects that are already selected to avoid putting the same object in the selection set more than once. Calling EnableAlreadySelectedObjectSelect = true overrides that restriction and allows selected objects to be selected and returned by GetObjects. This is useful because, coupled with the return immediately mode of GetObjects(1, -1), it is possible to select a selected object to deselect when the selected objects are being managed outside GetObjects() as in the case of CRhinoPolyEdge::GetEdge().
Public propertyBottomObjectPreference
By default, if a call to Input is permitted to select different parts of the same object, like a polysurface, a surface and an edge, then the top-most object is preferred. (polysurface beats face beats edge). If you want the bottom most object to be preferred, then call EnableBottomObjectPreference = true before calling GetObjects().
Public propertyChooseOneQuestion
By default, if a call to Input is permitted to select different parts of the same object, like a polysurface and an edge of that polysurface, then the top-most object is automatically selected. If you want the choose-one-object mechanism to include pop up in these cases, then call EnableChooseOneQuestion = true before calling GetObjects().
Public propertyCode exampleDeselectAllBeforePostSelect
true if pre-selected input will be deselected before post-selection begins when no pre-selected input is valid.
Public propertyCode exampleGeometryAttributeFilter
The geometry attribute filter provides a secondary filter that can be used to restrict which objects can be selected. Control of the type of geometry (points, curves, surfaces, meshes, etc.) is provided by GetObject.SetGeometryFilter. The geometry attribute filter is used to require the selected geometry to have certain attributes (open, closed, etc.). The default attribute filter permits selection of all types of geometry.
Public propertyCode exampleGeometryFilter
The geometry type filter controls which types of geometry (points, curves, surfaces, meshes, etc.) can be selected. The default geometry type filter permits selection of all types of geometry. NOTE: the filter can be a bitwise combination of multiple ObjectTypes.
Public propertyCode exampleGroupSelect
By default, groups are ignored in GetObject. If you want your call to GetObjects() to select every object in a group that has any objects selected, then enable group selection.
Public propertyInactiveDetailPickEnabled
By default, objects in inactive details are not permitted to be picked. In a few rare cases this is used (ex. picking circles during DimRadius)
Public propertyObjectCount
Gets the number of objects that were selected.
Public propertyObjectsWerePreselected
Public propertyCode exampleOneByOnePostSelect
In one-by-one post selection, the user is forced to select objects by post picking them one at a time.
Public propertyProxyBrepFromSubD
If a subd (or a subd component) cannot be selected, but a brep (or brep component) can be selected, then automatically create and use a proxy brep.
Public propertyCode exampleReferenceObjectSelect
By default, reference objects can be selected. If you do not want to be able to select reference objects, then call EnableReferenceObjectSelect=false.
Public propertySerialNumber
Each instance of GetObject has a unique runtime serial number that is used to identify object selection events associated with that instance.
Public propertyCode exampleSubObjectSelect
By default, GetObject.Input will permit a user to select sub-objects (like a curve in a b-rep or a curve in a group). If you only want the user to select "top" level objects, then call EnableSubObjectSelect = false.
Top
Methods
  NameDescription
Public methodStatic memberActiveGetObject
Get the currently running GetObject for a given document
Public methodAppendToPickList
Public methodClearObjects
Clear possible special object drawing
Public methodCustomGeometryFilter
Checks geometry to see if it can be selected. Override to provide fancy filtering.
Public methodDisablePreSelect
Public methodEnableClearObjectsOnEntry
By default the picked object list is cleared when GetObject.GetObjects() is called. If you are reusing a GetObject class and do not want the existing object list cleared when you call Input, then call EnableClearObjectsOnEntry(false) before calling GetObjects().
Public methodEnableHighlight
By default, any object post-pick selected by GetObjects() is highlighted. If you want to post-pick objects and not have them automatically highlight, then call EnableHighlight = false.
Public methodEnableIgnoreGrips
By default, post selection will select objects with grips on. If you do not want to be able to post select objects with grips on, then call EnableIgnoreGrips = false. The ability to preselect an object with grips on is determined by the value returned by the virtual RhinoObject.IsSelectableWithGripsOn.
Public methodEnablePostSelect
Control the availability of post selection in GetObjects.
Public methodEnablePreSelect
Control the pre-selection behavior GetObjects.
Public methodEnablePressEnterWhenDonePrompt
By default, when GetObject.GetObjects is called with minimumNumber > 0 and maximumNumber = 0, the command prompt automatically includes "Press Enter when done" after the user has selected at least minimumNumber of objects. If you want to prohibit the addition of the "Press Enter when done", then call EnablePressEnterWhenDonePrompt = false;
Public methodEnableSelPrevious
By default, any object selected during a command becomes part of the "previous selection set" and can be reselected by the SelPrev command. If you need to select objects but do not want them to be selected by a subsequent call to SelPrev, then call EnableSelPrev = false.
Public methodEnableUnselectObjectsOnExit
By default any objects in the object list are unselected when GetObject.GetObjects() exits with any return code besides Object. If you want to leave the objects selected when non-object input is returned, then call EnableUnselectObjectsOnExit(false) before calling GetObjects().
Public methodGet
Call to select a single object.
Public methodCode exampleGetMultiple
Call to select objects.
Public methodCode exampleObject
Public methodObjects
Public methodPassesGeometryAttributeFilter
Checks geometry to see if it passes the basic GeometryAttributeFilter.
Public methodCode exampleSetCustomGeometryFilter
Set filter callback function that will be called by the CustomGeometryFilter
Public methodSetPressEnterWhenDonePrompt
The default prompt when EnablePressEnterWhenDonePrompt is enabled is "Press Enter when done". Use this function to specify a different string to be appended.
Top
Examples
GetObject go = new GetObject(); go.GetObjects(1,0); if( go.CommandResult() != Command.Result.Success ) ... use canceled or some other type of input was provided int object_count = go.ObjectCount(); for( int i=0; i<object_count; i++ ) { ObjectReference objref = go.Object(i); ON_Geometry geo = objref.Geometry(); ... }
See Also