GetObject Methods |
The GetObject type exposes the following members.
Name | Description | |
---|---|---|
AcceptColor |
If you want to allow the user to be able to type in a color r,g,b or name
during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptColor(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a color,
then the result code GetResult.Color is returned and you can use RhinoGet.Color()
to get the value of the color. If the get accepts points, then the user will not
AcceptEnterWhenDone |
There are instances of RhinoGet that prompt with "Press Enter when Done." yet do not call AcceptNothing().
On the Mac, these instances need an additional call to AcceptEnterWhenDone() so the GetPointOptions dialog
AcceptNothing |
If you want to allow the user to be able to press enter in order to
skip selecting a something in GetPoint.Get(), GetObject::GetObjects(),
AcceptNumber |
If you want to allow the user to be able to type in a number during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptNumber() beforehand.
If the user chooses to type in a number, then the result code GetResult.Number is
returned and you can use RhinoGet.Number() to get the value of the number. If you
are using GetPoint and you want "0" to return (0,0,0) instead of the number zero,
AcceptPoint |
If you want to allow the user to be able to type in a point then call AcceptPoint(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a number, then
the result code GetResult.Point is returned and you can use RhinoGet.Point()
AcceptString |
If you want to allow the user to be able to type in a string during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptString(true) before calling
GetPoint()/GetObject(). If the user chooses to type in a string, then the result code
AcceptUndo |
If you want to allow the user to have an 'undo' option in GetPoint.Get(),
ActiveGetObject |
Get the currently running GetObject for a given document
AppendToPickList | ||
ClearObjects |
Clear possible special object drawing
| |
CustomGeometryFilter |
Checks geometry to see if it can be selected.
Override to provide fancy filtering.
| |
DisablePreSelect | ||
EnableClearObjectsOnEntry |
By default the picked object list is cleared when GetObject.GetObjects() is called.
If you are reusing a GetObject class and do not want the existing object list
cleared when you call Input, then call EnableClearObjectsOnEntry(false) before
calling GetObjects().
| |
EnableHighlight |
By default, any object post-pick selected by GetObjects() is highlighted.
If you want to post-pick objects and not have them automatically highlight,
then call EnableHighlight = false.
| |
EnableIgnoreGrips |
By default, post selection will select objects with grips on. If you do
not want to be able to post select objects with grips on, then call
EnableIgnoreGrips = false. The ability to preselect an object with grips
on is determined by the value returned by the virtual
RhinoObject.IsSelectableWithGripsOn.
| |
EnablePostSelect |
Control the availability of post selection in GetObjects.
| |
EnablePreSelect |
Control the pre-selection behavior GetObjects.
| |
EnablePressEnterWhenDonePrompt |
By default, when GetObject.GetObjects is called with minimumNumber > 0
and maximumNumber = 0, the command prompt automatically includes "Press Enter
when done" after the user has selected at least minimumNumber of objects. If
you want to prohibit the addition of the "Press Enter when done", then call
EnablePressEnterWhenDonePrompt = false;
| |
EnableSelPrevious |
By default, any object selected during a command becomes part of the
"previous selection set" and can be reselected by the SelPrev command.
If you need to select objects but do not want them to be selected by
a subsequent call to SelPrev, then call EnableSelPrev = false.
EnableUnselectObjectsOnExit |
By default any objects in the object list are unselected when GetObject.GetObjects()
exits with any return code besides Object. If you want to leave the objects
selected when non-object input is returned, then call EnableUnselectObjectsOnExit(false)
before calling GetObjects().
| |
Get |
Call to select a single object.
| |
GotDefault |
Returns true if user pressed Enter to accept a default point, number,
Line2d |
Returns two points defining the location in the view window of the 2d line selected
Object | ||
Objects | ||
PassesGeometryAttributeFilter |
Checks geometry to see if it passes the basic GeometryAttributeFilter.
| |
PickRectangle |
If the get was a GetObjects() and the mouse was used to select the objects,
then the returned rectangle has left < right and top < bottom. This rectangle
is the Windows GDI screen coordinates of the picking rectangle.
Point2d |
Returns location in view of point in selected in GetPoint::Get() or GetPoint::Get2dPoint().
Rectangle2d |
Returns the location in the view of the 2d rectangle selected in GetPoint::Get2dRectangle().
rect.left < rect.right and rect.top < rect.bottom
SetCommandPromptDefault |
Sets message that describes what default value will be used if the user presses enter.
This description appears in angle brackets <> in the command prompt window. You do
SetCustomGeometryFilter |
Set filter callback function that will be called by the CustomGeometryFilter
SetDefaultString |
Sets a string as default value that will be returned
SetPressEnterWhenDonePrompt |
The default prompt when EnablePressEnterWhenDonePrompt is enabled is "Press Enter
when done". Use this function to specify a different string to be appended.