Click or drag to resize

GetPoint Class

Used to interactively get a point.
Inheritance Hierarchy

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetPoint : GetBaseClass

The GetPoint type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleGetPoint
Create a new GetPoint.
Top
Properties
  NameDescription
Public propertyDynamicDrawColor
Color used by CRhinoGetPoint::DynamicDraw to draw the current point and the line from the base point to the current point.
Public propertyFullFrameRedrawDuringGet
In the "RARE" case that you need to draw some depth buffered geometry during a Get() operation, setting this value to true will force entire frames to be redrawn while the user moves the mouse. This allows DisplayPipeline events to be triggered as well as OnPostDrawObjects NOTE!! Setting this value to true comes with a significant performance penalty because the scene needs to be fully regenerated every frame where the standard DynamicDraw event draws temporary decorations (geometry) on top of a static scene.
Public propertyOsnapEventType
Gets the type of object snap used to obtain the point.
Public propertyCode exampleTag
Gets or sets an arbitrary object that can be attached to this GetPoint instance. Useful for passing some/ information that you may need in a DynamicDraw event since you can get at this Tag from the GetPointDrawEventArgs.
Top
Methods
  NameDescription
Public methodAddConstructionPoint
Adds a point to the list of construction points.
Public methodAddConstructionPoints
Adds points to the list of construction points.
Public methodAddSnapPoint
Adds a point to the list of osnap points.
Public methodAddSnapPoints
Adds points to the list of osnap points.
Public methodCode exampleClearConstraints
Removes any explicit constraints added by calls to GetPoint::Constraint() and enable the built-in constraint options.
Public methodClearConstructionPoints
Remove all construction points.
Public methodClearSnapPoints
Remove all snap points.
Public methodConstrain(Arc)
Constrains the picked point to lie on an arc.
Public methodConstrain(Circle)
Constrains the picked point to lie on a circle.
Public methodConstrain(Cylinder)
Constrains the picked point to lie on a cylinder.
Public methodCode exampleConstrain(Line)
Constrains the picked point to lie on a line.
Public methodConstrain(Sphere)
Constrains the picked point to lie on a sphere.
Public methodCode exampleConstrain(Curve, Boolean)
Constrains the picked point to lie on a curve.
Public methodConstrain(Mesh, Boolean)
Constrains the picked point to lie on a mesh.
Public methodConstrain(Plane, Boolean)
constrain the picked point to lie on a plane.
Public methodCode exampleConstrain(Point3d, Point3d)
Constrains the picked point to lie on a line.
Public methodCode exampleConstrain(Surface, Boolean)
Constrains the picked point to lie on a surface.
Public methodConstrain(Brep, Int32, Int32, Boolean)
Constrains the picked point to lie on a brep.
Public methodConstrainDistanceFromBasePoint
Sets distance constraint from base point.
Public methodCode exampleConstrainToConstructionPlane
If enabled, the picked point is constrained to be on the active construction plane. If the base point is set, then the point is constrained to be on the plane that contains the base point and is parallel to the active construction plane. By default this constraint is enabled.
Public methodConstrainToTargetPlane
Constrains point to lie on a plane that is parallel to the viewing plane and passes through the view's target point.
Public methodConstrainToVirtualCPlaneIntersection
If enabled, the picked point is constrained to be on the intersection of the plane and the virtual CPlane going through the plane origin. If the planes are parallel, the constraint works just like planar constraint.
Public methodCode exampleDrawLineFromPoint
Use DrawLineFromPoint() if you want a dynamic line drawn from a point to the point being picked.
Public methodEnableCurveSnapArrow
Controls display of the curve snap arrow icon.
Public methodEnableCurveSnapPerpBar
Controls display of the curve snap perpendicular bar icon.
Public methodEnableCurveSnapTangentBar
Controls display of the curve snap tangent bar icon.
Public methodEnableDrawLineFromPoint
Controls drawing of dynamic a line from the start point.
Public methodEnableNoRedrawOnExit
The default functionality of the GetPoint operation is to perform a redraw on exit. Calling this function with true turns off automatic redraw at the end of GetPoint. May be needed in some commands for flicker free feedback. When set to true, the caller is responsible for cleaning up the screen after GetPoint.
Public methodEnableObjectSnapCursors
Enables or disables object snap cursors. By default, object snap cursors are enabled.
Public methodEnableSnapToCurves
If you want GetPoint() to try to snap to curves when the mouse is near a curve (like the center point in the Circle command when the AroundCurve option is on), then enable the snap to curves option.
Public methodCode exampleGet
After setting up options and so on, call GetPoint::Get to get a 3d point. The point is retrieved when the mouse goes down.
Public methodGet(Boolean)
After setting up options and so on, call this method to get a 3d point.
Public methodGet(Boolean, Boolean)
After setting up options and so on, call this method to get a 2d or 3d point.
Public methodGetConstructionPoints
Gets current construction points.
Public methodGetPlanarConstraint
Public methodGetSnapPoints
Gets current snap points.
Public methodInterruptMouseMove
If you have lengthy computations in OnMouseMove() and/or DymanicDraw() overrides, then periodically call InterruptMouseMove() to see if you should interrupt your work because the mouse has moved again.
Public methodNumberPreview
If the user is typing a number, but hasn't pressed Enter, true is returned, along with the number the user typed.
Protected methodCode exampleOnDynamicDraw
Default calls the DynamicDraw event.
Protected methodOnMouseDown
Default calls the MouseDown event.
Protected methodOnMouseMove
Calls the MouseMove event and can/should be called by overriding implementation.
Protected methodOnPostDrawObjects
In the "rare" case that you need to draw some depth buffered geometry during a GetPoint operation, override the OnPostDrawObjects function. NOTE!! Overriding this function comes with a significant performance penalty because the scene needs to be fully regenerated every frame where the standard DynamicDraw event draws temporary decorations (geometry) on top of a static scene.
Public methodPermitConstraintOptions
Control the availability of the built-in linear, planar, curve, and surface constraint options like "Along", "AlongPerp", "AlongTan", "AlongParallel", "Between", "OnCrv", "OnSrf", ".x", ".y", ".z", ".xy", etc.
Public methodPermitElevatorMode
Permits the use of the control key to define a line constraint.
Public methodPermitFromOption
Control the availability of the built-in "From" option. By default, the "From" option is enabled.
Public methodPermitObjectSnap
By default, object snaps like "end", "near", etc. are controlled by the user. If you want to disable this ability, then call PermitObjectSnap(false).
Public methodPermitOrthoSnap
Controls availability of ortho snap. Default is true.
Public methodPermitTabMode
Permits the use of the tab key to define a line constraint.
Public methodPointOnBrep
Use to determine if point was on a Brep face. If the point was on a Brep face, then the (u,v) are the face parameters for the point.
Public methodCode examplePointOnCurve
Use to determine is point was on a curve.
Public methodPointOnObject
Call this function to see if the point was on an object. If the point was on an object an ObjRef is returned; otherwise null is returned.
Public methodPointOnSurface
Use to determine if point was on a surface. If the point was on a surface, then the (u,v) are the surface parameters for the point. The point returned by Point() is the same as surface.PointAt(u,v).
Public methodCode exampleSetBasePoint
Sets a base point used by ortho snap, from snap, planar snap, etc.
Public methodSetCursor
Sets cursor that will be used when Get() is called and snap is not happening.
Public methodTryGetBasePoint
Top
Events
  NameDescription
Public eventDynamicDraw
Event to use if you want to dynamically draw things as the mouse/digitizer moves. Every time the mouse moves, DynamicDraw will be called once per viewport. The calls to DynamicDraw happen AFTER the call to MouseMove. If you are drawing anything that takes a long time, periodically call InterruptMouseMove() to see if you should stop.
Public eventMouseDown
Called during Get2dRectangle, Get2dLine, and GetPoint(..,true) when the mouse down event for the initial point occurs. This function is not called during ordinary point getting because the mouse down event terminates an ordinary point get and returns a GetResult.Point result.
Public eventMouseMove
Called every time the mouse moves. MouseMove is called once per mouse move and is called BEFORE any calls to OnDynamicDraw. If you are doing anything that takes a long time, periodically call InterruptMouseMove() to see if you should stop. If the view is such that the 2d screen point can't be mapped to a 3d point, the 'point' argument will be Unset.
Public eventPostDrawObjects
Same as the DisplayPipeline.PostDrawObjects, but only works during the operation of the Get() function. NOTE: You must set FullFrameRedrawDuringGet to true in order for this event to be called.
Top
See Also