GetPointConstrain Method (Plane, Boolean) |
constrain the picked point to lie on a plane.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Constrain(
Plane plane,
bool allowElevator
)
Public Function Constrain (
plane As Plane,
allowElevator As Boolean
) As Boolean
Parameters
- plane
- Type: Rhino.GeometryPlane
A plane to use as constraint. - allowElevator
- Type: SystemBoolean
true if elevator mode should be allowed at user request.
Return Value
Type:
Booleantrue if constraint could be applied.
See Also