GetPoint Methods |
The GetPoint type exposes the following members.
Name | Description | |
---|---|---|
AcceptColor |
If you want to allow the user to be able to type in a color r,g,b or name
during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptColor(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a color,
then the result code GetResult.Color is returned and you can use RhinoGet.Color()
to get the value of the color. If the get accepts points, then the user will not
AcceptEnterWhenDone |
There are instances of RhinoGet that prompt with "Press Enter when Done." yet do not call AcceptNothing().
On the Mac, these instances need an additional call to AcceptEnterWhenDone() so the GetPointOptions dialog
AcceptNothing |
If you want to allow the user to be able to press enter in order to
skip selecting a something in GetPoint.Get(), GetObject::GetObjects(),
AcceptNumber |
If you want to allow the user to be able to type in a number during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptNumber() beforehand.
If the user chooses to type in a number, then the result code GetResult.Number is
returned and you can use RhinoGet.Number() to get the value of the number. If you
are using GetPoint and you want "0" to return (0,0,0) instead of the number zero,
AcceptPoint |
If you want to allow the user to be able to type in a point then call AcceptPoint(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a number, then
the result code GetResult.Point is returned and you can use RhinoGet.Point()
AcceptString |
If you want to allow the user to be able to type in a string during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptString(true) before calling
GetPoint()/GetObject(). If the user chooses to type in a string, then the result code
AcceptUndo |
If you want to allow the user to have an 'undo' option in GetPoint.Get(),
AddConstructionPoint |
Adds a point to the list of construction points.
| |
AddConstructionPoints |
Adds points to the list of construction points.
AddSnapPoint |
Adds a point to the list of osnap points.
| |
AddSnapPoints |
Adds points to the list of osnap points.
| |
ClearConstraints |
Removes any explicit constraints added by calls to GetPoint::Constraint() and enable
the built-in constraint options.
| |
ClearConstructionPoints |
Remove all construction points.
ClearSnapPoints |
Remove all snap points.
| |
Constrain(Arc) | Constrains the picked point to lie on an arc. | |
Constrain(Circle) | Constrains the picked point to lie on a circle. | |
Constrain(Cylinder) | Constrains the picked point to lie on a cylinder. | |
Constrain(Line) | Constrains the picked point to lie on a line. | |
Constrain(Sphere) | Constrains the picked point to lie on a sphere. | |
Constrain(Curve, Boolean) | Constrains the picked point to lie on a curve. | |
Constrain(Mesh, Boolean) | Constrains the picked point to lie on a mesh. | |
Constrain(Plane, Boolean) | constrain the picked point to lie on a plane. | |
Constrain(Point3d, Point3d) | Constrains the picked point to lie on a line. | |
Constrain(Surface, Boolean) | Constrains the picked point to lie on a surface. | |
Constrain(Brep, Int32, Int32, Boolean) | Constrains the picked point to lie on a brep. | |
ConstrainDistanceFromBasePoint |
Sets distance constraint from base point.
| |
ConstrainToConstructionPlane |
If enabled, the picked point is constrained to be on the active construction plane.
If the base point is set, then the point is constrained to be on the plane that contains
the base point and is parallel to the active construction plane. By default this
constraint is enabled.
| |
ConstrainToTargetPlane |
Constrains point to lie on a plane that is parallel to the
viewing plane and passes through the view's target point.
| |
ConstrainToVirtualCPlaneIntersection |
If enabled, the picked point is constrained to be on the
intersection of the plane and the virtual CPlane going through
the plane origin.
If the planes are parallel, the constraint works just like planar constraint.
| |
DrawLineFromPoint |
Use DrawLineFromPoint() if you want a dynamic line drawn from a point to the point being picked.
| |
EnableCurveSnapArrow |
Controls display of the curve snap arrow icon.
| |
EnableCurveSnapPerpBar |
Controls display of the curve snap perpendicular bar icon.
| |
EnableCurveSnapTangentBar |
Controls display of the curve snap tangent bar icon.
| |
EnableDrawLineFromPoint |
Controls drawing of dynamic a line from the start point.
| |
EnableNoRedrawOnExit |
The default functionality of the GetPoint operation is to perform a redraw on exit.
Calling this function with true turns off automatic redraw at the end of GetPoint.
May be needed in some commands for flicker free feedback.
When set to true, the caller is responsible for cleaning up the screen
after GetPoint.
| |
EnableObjectSnapCursors |
Enables or disables object snap cursors. By default, object snap cursors are enabled.
| |
EnableSnapToCurves |
If you want GetPoint() to try to snap to curves when the mouse is near a curve
(like the center point in the Circle command when the AroundCurve option is on),
then enable the snap to curves option.
Get |
After setting up options and so on, call GetPoint::Get to get a 3d point. The
point is retrieved when the mouse goes down.
| |
Get(Boolean) |
After setting up options and so on, call this method to get a 3d point.
| |
Get(Boolean, Boolean) |
After setting up options and so on, call this method to get a 2d or 3d point.
| |
GetConstructionPoints |
Gets current construction points.
| |
GetSnapPoints |
Gets current snap points.
| |
GotDefault |
Returns true if user pressed Enter to accept a default point, number,
InterruptMouseMove |
If you have lengthy computations in OnMouseMove() and/or DymanicDraw()
overrides, then periodically call InterruptMouseMove() to see if you
should interrupt your work because the mouse has moved again.
NumberPreview |
If the user is typing a number, but hasn't pressed Enter,
true is returned, along with the number the user typed.
| |
OnDynamicDraw | Default calls the DynamicDraw event. | |
OnMouseDown | Default calls the MouseDown event. | |
OnMouseMove | Calls the MouseMove event and can/should be called by overriding implementation. | |
OnPostDrawObjects |
In the "rare" case that you need to draw some depth buffered geometry during
a GetPoint operation, override the OnPostDrawObjects function.
NOTE!! Overriding this function comes with a significant performance penalty because the
scene needs to be fully regenerated every frame where the standard
DynamicDraw event draws temporary decorations (geometry) on top of a static scene.
| |
PermitConstraintOptions |
Control the availability of the built-in linear, planar, curve, and surface
constraint options like "Along", "AlongPerp", "AlongTan", "AlongParallel",
"Between", "OnCrv", "OnSrf", ".x", ".y", ".z", ".xy", etc.
| |
PermitElevatorMode |
Permits the use of the control key to define a line constraint.
| |
PermitFromOption |
Control the availability of the built-in "From" option. By default, the "From" option is enabled.
| |
PermitObjectSnap |
By default, object snaps like "end", "near", etc. are controlled by the user.
If you want to disable this ability, then call PermitObjectSnap(false).
| |
PermitOrthoSnap |
Controls availability of ortho snap. Default is true.
| |
PermitTabMode |
Permits the use of the tab key to define a line constraint.
| |
PickRectangle |
If the get was a GetObjects() and the mouse was used to select the objects,
then the returned rectangle has left < right and top < bottom. This rectangle
is the Windows GDI screen coordinates of the picking rectangle.
Point2d |
Returns location in view of point in selected in GetPoint::Get() or GetPoint::Get2dPoint().
PointOnBrep |
Use to determine if point was on a Brep face. If the point was on a Brep face,
then the (u,v) are the face parameters for the point.
| |
PointOnCurve |
Use to determine is point was on a curve.
| |
PointOnObject |
Call this function to see if the point was on an object. If the point was
on an object an ObjRef is returned; otherwise null is returned.
| |
PointOnSurface |
Use to determine if point was on a surface. If the point was on a surface,
then the (u,v) are the surface parameters for the point. The point returned
by Point() is the same as surface.PointAt(u,v).
SetBasePoint |
Sets a base point used by ortho snap, from snap, planar snap, etc.
SetCommandPromptDefault |
Sets message that describes what default value will be used if the user presses enter.
This description appears in angle brackets <> in the command prompt window. You do
SetCursor |
Sets cursor that will be used when Get() is called and snap is not
happening.
SetDefaultString |
Sets a string as default value that will be returned
SetWaitDuration |
Sets the wait duration (in milliseconds) of the getter. If the duration passes without