GetPointAddSnapPoint Method |
Adds a point to the list of osnap points.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int AddSnapPoint(
Point3d point
)
Public Function AddSnapPoint (
point As Point3d
) As Integer
Parameters
- point
- Type: Rhino.GeometryPoint3d
A point.
Return Value
Type:
Int32Total number of snap points.
Remarks
When point osnap is enabled, GetPoint will snap to points in the Rhino model.
If you want the user to be able to snap to additional points, then use
GetPoint::AddSnapPoints to specify the locations of these additional points.
See Also