GetPointAddConstructionPoints Method |
Adds points to the list of construction points.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int AddConstructionPoints(
Point3d[] points
)
Public Function AddConstructionPoints (
points As Point3d()
) As Integer
Parameters
- points
- Type: Rhino.GeometryPoint3d
An array of points to be added.
Return Value
Type:
Int32Total number of construction points.
Remarks
Construction points are like snap points except that they get snapped to even when
point osnap is off. Typically, there are only a few construction points while there
can be many snap points. For example, when polylines are drawn the start point is a
construction point and the other points are snap points.
See Also