GetPointConstrain Method (Mesh, Boolean) |
Constrains the picked point to lie on a mesh.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Constrain(
Mesh mesh,
bool allowPickingPointOffObject
)
Public Function Constrain (
mesh As Mesh,
allowPickingPointOffObject As Boolean
) As Boolean
Parameters
- mesh
- Type: Rhino.GeometryMesh
A mesh to use as constraint. - allowPickingPointOffObject
- Type: SystemBoolean
defines whether the point pick is allowed to happen off object. When false,
a "no no" cursor is shown when the cursor is not on the object. When true,
a normal point picking cursor is used and the marker is visible also when
the cursor is not on the object.
Return Value
Type:
Booleantrue if constraint could be applied.
See Also