GetTransformCalculateTransform Method |
Retrieves the final transformation.
Override this virtual function to provide your own custom transformation method.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public abstract Transform CalculateTransform(
RhinoViewport viewport,
Point3d point
)
Public MustOverride Function CalculateTransform (
viewport As RhinoViewport,
point As Point3d
) As Transform
Parameters
- viewport
- Type: Rhino.DisplayRhinoViewport
A Rhino viewport that the user is using. - point
- Type: Rhino.GeometryPoint3d
A point that the user is selecting.
Return Value
Type:
TransformA transformation matrix value.
See Also