GetTransform Methods |
The GetTransform type exposes the following members.
Name | Description | |
---|---|---|
AcceptColor |
If you want to allow the user to be able to type in a color r,g,b or name
during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptColor(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a color,
then the result code GetResult.Color is returned and you can use RhinoGet.Color()
to get the value of the color. If the get accepts points, then the user will not
AcceptEnterWhenDone |
There are instances of RhinoGet that prompt with "Press Enter when Done." yet do not call AcceptNothing().
On the Mac, these instances need an additional call to AcceptEnterWhenDone() so the GetPointOptions dialog
AcceptNothing |
If you want to allow the user to be able to press enter in order to
skip selecting a something in GetPoint.Get(), GetObject::GetObjects(),
AcceptNumber |
If you want to allow the user to be able to type in a number during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptNumber() beforehand.
If the user chooses to type in a number, then the result code GetResult.Number is
returned and you can use RhinoGet.Number() to get the value of the number. If you
are using GetPoint and you want "0" to return (0,0,0) instead of the number zero,
AcceptPoint |
If you want to allow the user to be able to type in a point then call AcceptPoint(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a number, then
the result code GetResult.Point is returned and you can use RhinoGet.Point()
AcceptString |
If you want to allow the user to be able to type in a string during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptString(true) before calling
GetPoint()/GetObject(). If the user chooses to type in a string, then the result code
AcceptUndo |
If you want to allow the user to have an 'undo' option in GetPoint.Get(),
AddTransformObjects |
Adds any objects you want transformed and grips you want transformed.
Make sure no duplicates are in the list and that no grip owners are
passed in as objects.
| |
CalculateTransform |
Retrieves the final transformation.
Override this virtual function to provide your own custom transformation method. | |
ClearConstraints |
Removes any explicit constraints added by calls to GetPoint::Constraint() and enable
ConstrainToConstructionPlane |
If enabled, the picked point is constrained to be on the active construction plane.
If the base point is set, then the point is constrained to be on the plane that contains
the base point and is parallel to the active construction plane. By default this
ConstrainToTargetPlane |
Constrains point to lie on a plane that is parallel to the
ConstrainToVirtualCPlaneIntersection |
If enabled, the picked point is constrained to be on the
intersection of the plane and the virtual CPlane going through
the plane origin.
EnableNoRedrawOnExit |
The default functionality of the GetPoint operation is to perform a redraw on exit.
Calling this function with true turns off automatic redraw at the end of GetPoint.
May be needed in some commands for flicker free feedback.
When set to true, the caller is responsible for cleaning up the screen
EnableSnapToCurves |
If you want GetPoint() to try to snap to curves when the mouse is near a curve
(like the center point in the Circle command when the AroundCurve option is on),
Get |
After setting up options and so on, call GetPoint::Get to get a 3d point. The
GetXform |
Gets the Transformation.
InterruptMouseMove |
If you have lengthy computations in OnMouseMove() and/or DymanicDraw()
overrides, then periodically call InterruptMouseMove() to see if you
Line2d |
Returns two points defining the location in the view window of the 2d line selected
NumberPreview |
If the user is typing a number, but hasn't pressed Enter,
OnPostDrawObjects |
In the "rare" case that you need to draw some depth buffered geometry during
a GetPoint operation, override the OnPostDrawObjects function.
NOTE!! Overriding this function comes with a significant performance penalty because the
scene needs to be fully regenerated every frame where the standard
PermitConstraintOptions |
Control the availability of the built-in linear, planar, curve, and surface
constraint options like "Along", "AlongPerp", "AlongTan", "AlongParallel",
PermitObjectSnap |
By default, object snaps like "end", "near", etc. are controlled by the user.
PickRectangle |
If the get was a GetObjects() and the mouse was used to select the objects,
then the returned rectangle has left < right and top < bottom. This rectangle
is the Windows GDI screen coordinates of the picking rectangle.
Point2d |
Returns location in view of point in selected in GetPoint::Get() or GetPoint::Get2dPoint().
PointOnBrep |
Use to determine if point was on a Brep face. If the point was on a Brep face,
PointOnObject |
Call this function to see if the point was on an object. If the point was
PointOnSurface |
Use to determine if point was on a surface. If the point was on a surface,
then the (u,v) are the surface parameters for the point. The point returned
Rectangle2d |
Returns the location in the view of the 2d rectangle selected in GetPoint::Get2dRectangle().
rect.left < rect.right and rect.top < rect.bottom
SetCommandPromptDefault |
Sets message that describes what default value will be used if the user presses enter.
This description appears in angle brackets <> in the command prompt window. You do
SetCursor |
Sets cursor that will be used when Get() is called and snap is not
SetDefaultString |
Sets a string as default value that will be returned
SetWaitDuration |
Sets the wait duration (in milliseconds) of the getter. If the duration passes without