Click or drag to resize

GeometryAttributeFilter Enumeration

If an object passes the geometry TYPE filter, then the geometry ATTRIBUTE filter is applied.

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
[FlagsAttribute]
public enum GeometryAttributeFilter
Members
  Member nameValueDescription
WireCurve1 3d wire curve If you want to accept only wire or edge curves, then specify wire_curve or edge_curve, otherwise both wire and edge curves will pass the attribute filter.
EdgeCurve2 3d curve of a surface edge If you want to accept only wire or edge curves, then specify wire_curve or edge_curve, otherwise both wire and edge curves will pass the attribute filter.
ClosedCurve4 Closed Curves and Edges are acceptable If you want to accept only closed or open curves, then specify either closed_curve or open_curve. Otherwise both closed and open curves will pass the attribute filter.
OpenCurve8 Open Curves and Edges are acceptable If you want to accept only closed or open curves, then specify either closed_curve or open_curve. Otherwise both closed and open curves will pass the attribute filter.
SeamEdge16 seam edges are acceptable attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
ManifoldEdge32 edges with 2 different surfaces pass attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
NonmanifoldEdge64 edges with 3 or more surfaces pass attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
MatedEdge112 any mated edge passes attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
SurfaceBoundaryEdge128 boundary edges on surface sides pass attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
TrimmingBoundaryEdge256 boundary edges that trim a surface pass attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
BoundaryEdge384 ant boundary edge passes attributes of acceptable trimming edge objects (associated with an ON_BrepTrim). If none of these attributes are explicitly specified, then any kind of trimming edge will pass the attribute filter.
ClosedSurface512 If you want to accept only closed or open surfaces, then specify either closed_surface or open_surface. Otherwise both closed and open surfaces will pass the attribute filter.
OpenSurface1024 If you want to accept only closed or open surfaces, then specify either closed_surface or open_surface. Otherwise both closed and open surfaces will pass the attribute filter.
TrimmedSurface2048 If you want to accept only trimmed or untrimmed surfaces, then specify either trimmed_surface or untrimmed_surface. Otherwise both trimmed and untrimmed surfaces will pass the attribute filter.
UntrimmedSurface4096 If you want to accept only trimmed or untrimmed surfaces, then specify either trimmed_surface or untrimmed_surface. Otherwise both trimmed and untrimmed surfaces will pass the attribute filter.
SubSurface8192 If you want to accept only sub-surfaces of (multi-surface) polysurface, then specify sub_surface. If you do not want to accept sub-surfaces, then specify top_surface. Otherwise sub-surfaces and top surfaces will pass the attribute filter.
TopSurface16384 If you want to accept only sub-surfaces of (multi-surface) polysurface, then specify sub_surface. If you do not want to accept sub-surfaces, then specify top_surface. Otherwise sub-surfaces and top surfaces will pass the attribute filter.
ManifoldPolysrf32768 If you want to accept only manifold or non-manifold polysurfaces, then specify manifold_polysrf or nonmanifold_polysrf. Otherwise both manifold and non-manifold polysurfaces will pass the attribute filter.
NonmanifoldPolysrf65536 If you want to accept only manifold or non-manifold polysurfaces, then specify manifold_polysrf or nonmanifold_polysrf. Otherwise both manifold and non-manifold polysurfaces will pass the attribute filter.
ClosedPolysrf131072 If you want to accept only closed or open polysurfaces, then specify either closed_polysrf or open_polysrf. Otherwise both closed and open polysurfaces will pass the attribute filter.
OpenPolysrf262144 If you want to accept only closed or open polysurfaces, then specify either closed_polysrf or open_polysrf. Otherwise both closed and open polysurfaces will pass the attribute filter.
ClosedMesh524288 If you want to accept only closed or open meshes, then specify either closed_mesh or open_mesh. Otherwise both closed and open meshes will pass the attribute filter.
OpenMesh1048576 If you want to accept only closed or open meshes, then specify either closed_mesh or open_mesh. Otherwise both closed and open meshes will pass the attribute filter.
BoundaryInnerLoop2097152all trimming edges are boundary edges.
MatedInnerLoop4194304all trimming edges are mated.
InnerLoop6291456any inner loop is acceptable.
BoundaryOuterLoop8388608all trimming edges are boundary edges.
MatedOuterLoop16777216all trimming edges are mated.
OuterLoop25165824any outer loop is acceptable.
SpecialLoop33554432slit, curve-on-surface, point-on-surface, etc.
AcceptAllAttributes4294967295
See Also