Click or drag to resize

GetCircle Class

[Missing <summary> documentation for "T:Rhino.Input.Custom.GetCircle"]

Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetCircle

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetCircle : IDisposable

The GetCircle type exposes the following members.

Constructors
  NameDescription
Public methodGetCircle
Initializes a new instance of the GetCircle class
Top
Properties
  NameDescription
Public propertyAllowDeformable
Allow for deformable options
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyDeformable
Is the deformable option set
Public propertyDeformableDegree
Public propertyDeformablePointCount
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Perform the 'get' operation.
Top
See Also