Click or drag to resize

GetEllipsoid Class

Class provides user interface to define an ellipsoid.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetEllipsoid

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public class GetEllipsoid : IDisposable

The GetEllipsoid type exposes the following members.

Constructors
  NameDescription
Public methodGetEllipsoid
Initializes a new instance of the GetEllipsoid class
Top
Properties
  NameDescription
Public propertyFirstPoint
Returns the first point. If in "from foci" mode, then this is the first foci point.
Public propertyIsModeFromFoci
Indicates the ellipsoid was created from foci.
Public propertyMarkFoci
Indicates the user wants the ellipsoid foci marked with point objects.
Public propertySecondPoint
Returns the second point. If in "from foci" mode, then this is the second foci point.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of an ellipsoid.
Public methodGetMesh(Int32, Int32, Mesh)
Prompt for the getting of a mesh ellipsoid.
Public methodGetMesh(Int32, Int32, Boolean, Mesh)
Prompt for the getting of a mesh ellipsoid.
Top
See Also