Click or drag to resize

GetLine Class

Use to interactively get a line. The Rhino "Line" command uses GetLine.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetLine

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetLine : IDisposable

The GetLine type exposes the following members.

Constructors
  NameDescription
Public methodGetLine
Initializes a new instance of the GetLine class
Top
Properties
  NameDescription
Public propertyAcceptZeroLengthLine
Controls whether or not a zero length line is acceptable. The default is to require the user to keep picking the end point until we get a point different than the start point.
Public propertyFeedbackColor
If set, the feedback color is used to draw the dynamic line when the second point is begin picked. If not set, the active layer color is used.
Public propertyFirstPointPrompt
Prompt when getting first point
Public propertyFixedLength
If FixedLength > 0, the line must have the specified length
Public propertyGetLineMode
Mode used
Public propertyHaveFeedbackColor
If true, the feedback color is used to draw the dynamic line when the second point is begin picked. If false, the active layer color is used.
Public propertyMidPointPrompt
Prompt when getting midpoint
Public propertySecondPointPrompt
Prompt when getting second point
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEnableAllVariations
If true, then all line variations are shown if the default line mode is used
Public methodEnableFromBothSidesOption
If true, then the "BothSides" option shows up when the start point is interactively picked.
Public methodEnableFromMidPointOption
If true, the "MidPoint" options shows up
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Perform the 'get' operation.
Public methodSetFirstPoint
Use SetFirstPoint to specify the line's starting point and skip the start point interactive picking
Top
See Also