Click or drag to resize

GetLine Methods

The GetLine type exposes the following members.

Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEnableAllVariations
If true, then all line variations are shown if the default line mode is used
Public methodEnableFromBothSidesOption
If true, then the "BothSides" option shows up when the start point is interactively picked.
Public methodEnableFromMidPointOption
If true, the "MidPoint" options shows up
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Perform the 'get' operation.
Public methodSetFirstPoint
Use SetFirstPoint to specify the line's starting point and skip the start point interactive picking
Top
See Also