Click or drag to resize

GetLine Properties

The GetLine type exposes the following members.

Properties
  NameDescription
Public propertyAcceptZeroLengthLine
Controls whether or not a zero length line is acceptable. The default is to require the user to keep picking the end point until we get a point different than the start point.
Public propertyFeedbackColor
If set, the feedback color is used to draw the dynamic line when the second point is begin picked. If not set, the active layer color is used.
Public propertyFirstPointPrompt
Prompt when getting first point
Public propertyFixedLength
If FixedLength > 0, the line must have the specified length
Public propertyGetLineMode
Mode used
Public propertyHaveFeedbackColor
If true, the feedback color is used to draw the dynamic line when the second point is begin picked. If false, the active layer color is used.
Public propertyMidPointPrompt
Prompt when getting midpoint
Public propertySecondPointPrompt
Prompt when getting second point
Top
See Also