Click or drag to resize

CommandLineOption Class

[Missing <summary> documentation for "T:Rhino.Input.Custom.CommandLineOption"]

Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomCommandLineOption

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class CommandLineOption

The CommandLineOption type exposes the following members.

Properties
  NameDescription
Public propertyCode exampleCurrentListOptionIndex
Public propertyCurrentNumericValue
Public propertyCurrentToggleValue
Public propertyEnglishName
The English command option name
Public propertyIndex
Public propertyLocalName
The localized command option name
Public propertyOptionType
The type of this command line option
Public propertyStringOptionValue
Assigned by RhinoGet.Get if an option value is specified in a script or by a command window control.
Top
Methods
  NameDescription
Public methodStatic memberIsValidOptionName
Test a string to see if it can be used as an option name in any of the RhinoGet::AddCommandOption...() functions.
Public methodStatic memberIsValidOptionValueName
Test a string to see if it can be used as an option value in RhinoGet::AddCommandOption, RhinoGet::AddCommandOptionToggle, or RhinoGet::AddCommandOptionList.
Public methodListOptions
If this OptionType is a list, then the option should contain a list of values that the user can pick from.
Public methodToggleValues
Top
See Also