Click or drag to resize

GetPolyline Class

Use to interactively get a polyline.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetPolyline

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetPolyline : IDisposable

The GetPolyline type exposes the following members.

Constructors
  NameDescription
Public methodGetPolyline
Initializes a new instance of the GetPolyline class
Top
Properties
  NameDescription
Public propertyFirstPointPrompt
Prompt when getting first point
Public propertyFourthPointPrompt
Prompt when getting fourth point
Public propertyMaxPointCount
Public propertyMinPointCount
Public propertySecondPointPrompt
Prompt when getting second point
Public propertyThirdPointPrompt
Prompt when getting third point
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Perform the 'get' operation.
Public methodSetFirstPoint
Use SetFirstPoint to specify the line's starting point and skip the start point interactive picking
Top
See Also