Click or drag to resize

GetSphere Class

Class provides user interface to define a sphere.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetSphere

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetSphere : IDisposable

The GetSphere type exposes the following members.

Constructors
  NameDescription
Public methodGetSphere
Initializes a new instance of the GetSphere class
Top
Properties
  NameDescription
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of a sphere.
Public methodGetMesh
Prompt for the getting of a mesh sphere.
Top
See Also