GetArc Class |
[Missing <summary> documentation for "T:Rhino.Input.Custom.GetArc"]
Namespace: Rhino.Input.Custom
The GetArc type exposes the following members.
Name | Description | |
---|---|---|
AllowDeformable | Allow for deformable options | |
DefaultRadius |
Default radius used for start and end radius
| |
Deformable | Is the deformable option set | |
DeformableDegree | ||
DeformablePointCount | ||
UseActiveLayerLinetypeForCurves |
Name | Description | |
---|---|---|
Dispose |
Actively reclaims unmanaged resources that this instance uses.
| |
Dispose(Boolean) |
For derived class implementers.
This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.) | |
Get | Perform the 'get' operation. | |