Click or drag to resize

GetTorus Class

Class provides user interface to define a torus.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetTorus

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetTorus : IDisposable

The GetTorus type exposes the following members.

Constructors
  NameDescription
Public methodGetTorus
Initializes a new instance of the GetTorus class
Top
Properties
  NameDescription
Public propertyAroundDirectionCount
The number of faces in the around direction.
Public propertyAroundDirectionMinimumCount
The minimum number of faces in the around direction.
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyFixInnerRadius
Second radius option. The first radius chosen sets the inner dimension of the torus and the second radius is constrained to be outside of the first radius.
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Public propertyInSecondDiameterMode
Second radius option. Determines if the second "size" value is representing a radius or diameter
Public propertyPromptForMeshDensity
Set true if you are prompting for a mesh or subd torus.
Public propertySecondSize
Second radius or diameter (based on InSecondDiameterMode)
Public propertyVerticalDirectionCount
The number of faces in the vertical direction.
Public propertyVerticalDirectionMinimumCount
The minimum number of faces in the vertical direction.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of a torus.
Public methodGetMesh
Prompt for the getting of a mesh torus.
Top
See Also