Click or drag to resize

GetTorus Properties

The GetTorus type exposes the following members.

Properties
  NameDescription
Public propertyAroundDirectionCount
The number of faces in the around direction.
Public propertyAroundDirectionMinimumCount
The minimum number of faces in the around direction.
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyFixInnerRadius
Second radius option. The first radius chosen sets the inner dimension of the torus and the second radius is constrained to be outside of the first radius.
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Public propertyInSecondDiameterMode
Second radius option. Determines if the second "size" value is representing a radius or diameter
Public propertyPromptForMeshDensity
Set true if you are prompting for a mesh or subd torus.
Public propertySecondSize
Second radius or diameter (based on InSecondDiameterMode)
Public propertyVerticalDirectionCount
The number of faces in the vertical direction.
Public propertyVerticalDirectionMinimumCount
The minimum number of faces in the vertical direction.
Top
See Also