Click or drag to resize

GetCylinder Class

Class provides user interface to define a cylinder.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetCylinder

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetCylinder : IDisposable

The GetCylinder type exposes the following members.

Constructors
  NameDescription
Public methodGetCylinder
Initializes a new instance of the GetCylinder class
Top
Properties
  NameDescription
Public propertyBothSidesOption
Determine if the "both sides" option is enabled
Public propertyCap
Gets or sets whether or not the output should be capped.
Public propertyCylinderConstraint
State of the cone/cylinder constraint option. When the cone/cylinder option is selected, the circle is being made as a base for a cone/cylinder. By default the vertical cone/cylinder option not available but is not selected. By default the "Vertical" option applies to VerticalCircle.
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyHeight
Height of cylinder
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of a cylinder.
Public methodGetMesh(Int32, Int32, Cylinder)
Prompt for the getting of a mesh cylinder.
Public methodGetMesh(Int32, Int32, Int32, Cylinder)
Prompt for the getting of a mesh cylinder.
Top
See Also