Click or drag to resize

GetEllipse Class

Class provides user interface to define an ellipse.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetEllipse

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetEllipse : IDisposable

The GetEllipse type exposes the following members.

Constructors
  NameDescription
Public methodGetEllipse
Constructs a GetEllispe object.
Top
Properties
  NameDescription
Public propertyFirstPoint
Returns the first point. If in "from foci" mode, then this is the first foci point.
Public propertyIsModeFromFoci
Indicates the ellipse was created from foci.
Public propertyMarkFoci
Indicates the user wants the ellipse foci marked with point objects.
Public propertySecondPoint
Returns the second point. If in "from foci" mode, then this is the second foci point.
Top
Methods
  NameDescription
Public methodDispose
Actively releases the unmanaged object.
Protected methodDispose(Boolean)
Releases the unmanaged object.
Protected methodFinalize
Passively releases the unmanaged object.
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of an ellipse.
Top
See Also