Click or drag to resize

PickContext Class

Utility for determining if objects are picked
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomPickContext

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class PickContext : IDisposable

The PickContext type exposes the following members.

Constructors
  NameDescription
Public methodPickContext
Initializes a new instance of the PickContext class
Top
Properties
  NameDescription
Public propertyGetObjectUsed
Public propertyPickGroupsEnabled
True if GroupObjects should be added to the pick list
Public propertyPickLine
pick chord starts on near clipping plane and ends on far clipping plane.
Public propertyPickMode
Public propertyPickStyle
Public propertySubObjectSelectionEnabled
True if the user had activated sub-object selection
Public propertyView
This view can be a model view or a page view. When view is a page view, then you need to distinguish between the viewports MainViewport() and ActiveViewport(). When m_view is a model view, both MainViewport() and ActiveViewport() return the world view's viewport.
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the PickContext
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the PickContext and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodPickFrustumTest(BoundingBox, Boolean)
Fast test to check if a bounding box intersects a pick frustum.
Public methodPickFrustumTest(Point3d, Double, Double)
Utility for picking 3d point
Public methodPickFrustumTest(BezierCurve, Double, Double, Double)
Public methodPickFrustumTest(Line, Double, Double, Double)
Public methodPickFrustumTest(NurbsCurve, Double, Double, Double)
Public methodPickFrustumTest(Point3d, Int32, Double, Double)
Public methodPickFrustumTest(PointCloud, Int32, Double, Double)
Public methodPickFrustumTest(Mesh, PickContextMeshPickStyle, Point3d, Double, Double, PickContextMeshHitFlag, Int32)
Utility for picking meshes
Public methodPickFrustumTest(Mesh, PickContextMeshPickStyle, Point3d, Point2d, Point2d, Double, Double, PickContextMeshHitFlag, Int32)
Utility for picking meshes
Public methodPickMeshTopologyVertices
Utility for picking mesh vertices
Public methodSetPickTransform
Public methodUpdateClippingPlanes
Updates the clipping plane information in pick region. The SetClippingPlanes and View fields must be called before calling UpdateClippingPlanes().
Top
See Also