The PickContext type exposes the following members.
Methods
| Name | Description |
---|
![Public method Public method](../icons/pubmethod.gif) | Dispose | |
![Protected method Protected method](../icons/protmethod.gif) | Dispose(Boolean) | |
![Public method Public method](../icons/pubmethod.gif) | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![Protected method Protected method](../icons/protmethod.gif) | Finalize | (Overrides ObjectFinalize.) |
![Public method Public method](../icons/pubmethod.gif) | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![Public method Public method](../icons/pubmethod.gif) | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![Protected method Protected method](../icons/protmethod.gif) | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(BoundingBox, Boolean) |
Fast test to check if a bounding box intersects a pick frustum.
|
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(Point3d, Double, Double) | Utility for picking 3d point |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(BezierCurve, Double, Double, Double) | |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(Line, Double, Double, Double) | |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(NurbsCurve, Double, Double, Double) | |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(Point3d, Int32, Double, Double) | |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(PointCloud, Int32, Double, Double) | |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(Mesh, PickContextMeshPickStyle, Point3d, Double, Double, PickContextMeshHitFlag, Int32) | Utility for picking meshes |
![Public method Public method](../icons/pubmethod.gif) | PickFrustumTest(Mesh, PickContextMeshPickStyle, Point3d, Point2d, Point2d, Double, Double, PickContextMeshHitFlag, Int32) | Utility for picking meshes |
![Public method Public method](../icons/pubmethod.gif) | PickMeshTopologyVertices |
Utility for picking mesh vertices
|
![Public method Public method](../icons/pubmethod.gif) | SetPickTransform | |
![Public method Public method](../icons/pubmethod.gif) | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![Public method Public method](../icons/pubmethod.gif) | UpdateClippingPlanes |
Updates the clipping plane information in pick region. The
SetClippingPlanes and View fields must be called before calling
UpdateClippingPlanes().
|
Top
See Also