Click or drag to resize

PickContextPickFrustumTest Method (BoundingBox, Boolean)

Fast test to check if a bounding box intersects a pick frustum.

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool PickFrustumTest(
	BoundingBox box,
	out bool boxCompletelyInFrustum
)

Parameters

box
Type: Rhino.GeometryBoundingBox

[Missing <param name="box"/> documentation for "M:Rhino.Input.Custom.PickContext.PickFrustumTest(Rhino.Geometry.BoundingBox,System.Boolean@)"]

boxCompletelyInFrustum
Type: SystemBoolean
Set to true if the box is completely contained in the pick frustum. When doing a window or crossing pick, you can immediately return a hit if the object's bounding box is completely inside of the pick frustum.

Return Value

Type: Boolean
False if bounding box is invalid or box does not intersect the pick frustum
See Also