Click or drag to resize

GetTruncatedCone Class

Class provides user interface to define a truncated cone.
Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomGetTruncatedCone

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GetTruncatedCone : IDisposable

The GetTruncatedCone type exposes the following members.

Constructors
  NameDescription
Public methodGetTruncatedCone
Initializes a new instance of the GetTruncatedCone class
Top
Properties
  NameDescription
Public propertyCap
Gets or sets whether or not the output should be capped.
Public propertyCylinderConstraint
State of the cone/cylinder constraint option. When the cone/cylinder option is selected, the circle is being made as a base for a cone/cylinder. By default the vertical cone/cylinder option not available but is not selected. By default the "Vertical" option applies to VerticalCircle.
Public propertyDefaultSize
Default radius or diameter (based on InDiameterMode)
Public propertyHeight
Height of truncated cone.
Public propertyInDiameterMode
Determines if the "size" value is representing a radius or diameter
Public propertySecondRadius
Radius of second circle.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet
Prompt for the getting of a truncated cone.
Public methodGetMesh(Int32, Int32, Mesh)
Prompt for the getting of a mesh truncated cone.
Public methodGetMesh(Int32, Int32, Int32, Mesh)
Prompt for the getting of a mesh truncated cone.
Top
See Also