Click or drag to resize

OptionDouble Class

[Missing <summary> documentation for "T:Rhino.Input.Custom.OptionDouble"]

Inheritance Hierarchy
SystemObject
  Rhino.Input.CustomOptionDouble

Namespace:  Rhino.Input.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class OptionDouble : IDisposable

The OptionDouble type exposes the following members.

Constructors
  NameDescription
Public methodOptionDouble(Double)
Initializes a new instance of the OptionDouble class
Public methodOptionDouble(Double, Boolean, Double)
Initializes a new instance of the double option class.
Public methodCode exampleOptionDouble(Double, Double, Double)
Initializes a new instance of the OptionDouble class with lower and upper limits.
Top
Properties
  NameDescription
Public propertyCode exampleCurrentValue
Public propertyInitialValue
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the OptionDouble
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the OptionDouble and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Top
See Also