RhinoObject Methods |
The RhinoObject type exposes the following members.
Name | Description | |
---|---|---|
ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) | |
ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) | |
ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) | |
CommitChanges |
Moves changes made to this RhinoObject into the RhinoDoc.
| |
ConstructConstObject |
Assigns a parent object and a sub-object index to this.
(Inherited from CommonObject.) | |
CopyHistoryOnReplace |
Gets the setting of the CopyOnReplace field in this object's history
| |
CreateMeshes |
Create meshes used to render and analyze surface and polysurface objects.
| |
CustomRenderMeshesBoundingBox |
Returns the bounding box of custom render primitives for this object .
| |
DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) | |
Description |
Get a brief description of a object, including it's attributes and geometry.
| |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) | |
Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. | |
DuplicateGeometry |
Constructs a deep (full) copy of the geometry.
| |
EnableCustomGrips | Turns on/off the object's editing grips. | |
EnableVisualAnalysisMode |
Used to turn analysis modes on and off.
| |
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) | |
FromRuntimeSerialNumber | Get a Rhino object for a unique runtime serial number | |
GetActiveVisualAnalysisModes |
Gets a list of currently enabled analysis modes for this object.
| |
GetBoundingBox |
Called when Rhino wants the bounding box of this object. Viewpoert can be null.
This is the default base class version that will go through to the C++ base class if it is called from the custom object
| |
GetCustomRenderMeshParameter |
Query the object for the value of a given named custom render mesh parameter.
| |
GetDynamicTransform |
While an object is being dynamically transformed (dragged, rotated, ...),
the current transformation can be retrieved and used for creating
dynamic display.
| |
GetFillSurfaces(RhinoObject, ClippingPlaneObject) |
Return list of fill surfaces if any for object and clipping plane.
| |
GetFillSurfaces(RhinoObject, IEnumerableClippingPlaneObject) |
Return list of fill surfaces if any for object and clipping plane. Fills are trimmed by
clipping planes that did not generate them.
| |
GetFillSurfaces(RhinoObject, IEnumerableClippingPlaneObject, Boolean) |
Return list of fill surfaces if any for object and clipping plane.
| |
GetGrips |
Returns grips for this object If grips are enabled. If grips are not
enabled, returns null.
| |
GetGroupList |
Allocates an array of group indices of length GroupCount.
If GroupCount is 0, then this method returns null.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetHighlightedSubObjects |
Gets a list of all highlighted sub-objects.
| |
GetMaterial(Boolean) |
Gets material that this object uses based on it's attributes and the document
that the object is associated with. In the rare case that a document is not
associated with this object, null will be returned.
| |
GetMaterial(ComponentIndex) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
then the top level material is returned.
| |
GetMaterial(ComponentIndex, Guid) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
then the top level material is returned.
| |
GetMaterial(ComponentIndex, Guid, ObjectAttributes) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset then the top level material
is returned.
| |
GetMeshes |
Get existing meshes used to render and analyze surface and polysurface objects.
| |
GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) | |
GetRenderMaterial(Boolean) |
Gets the RenderMaterial that this object uses based on it's attributes
and the document that the object is associated with. If there is no
RenderMaterial associated with this object then null is returned. If
null is returned you should call GetMaterial to get the material used
to render this object.
| |
GetRenderMaterial(ComponentIndex) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
| |
GetRenderMaterial(ComponentIndex, Guid) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
| |
GetRenderMaterial(ComponentIndex, Guid, ObjectAttributes) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
material used to render this object.
| |
GetRenderMeshes | Obsolete.
Gets the render meshes of some objects.
| |
GetRenderMeshesWithUpdatedTCs | Obsolete.
Gets the render meshes of some objects.
| |
GetRenderMeshParameters |
Returns the meshing parameters that this object uses for generating render meshes.
If this object does not have per-object meshing parameters, then the document's meshing parameters are returned.
| |
GetRenderMeshParameters(Boolean) |
Returns the meshing parameters that this object uses for generating render meshes.
| |
GetRenderPrimitiveList(ViewportInfo, DisplayPipelineAttributes) | Obsolete.
Build custom render mesh(es) for this object.
| |
GetRenderPrimitiveList(ViewportInfo, Boolean) | Obsolete.
Build custom render mesh(es) for this object.
| |
GetSelectedSubObjects | Get a list of all selected sub-objects. | |
GetSubObjects |
Explodes the object into sub-objects. It is up to the caller to add the returned objects to the document.
| |
GetTextureChannels |
Get a list of the texture mapping channel Id's associated with object.
| |
GetTextureMapping(Int32) | ||
GetTextureMapping(Int32, Transform) |
Get objects texture mapping
| |
GetTightBoundingBox(IEnumerableRhinoObject, BoundingBox) |
Gets a world XY-plane aligned tight bounding box from a collection of Rhino objects.
| |
GetTightBoundingBox(BoundingBox, Boolean, Transform) |
Get tight bounding box of this Rhino object. The Rhino object is not modified.
| |
GetTightBoundingBox(IEnumerableRhinoObject, Plane, BoundingBox) |
Gets a plane aligned tight bounding box from a collection of Rhino objects.
| |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
HasCustomRenderMeshes |
Returns true if the object will has a set of custom render primitives - ie, CustomRenderMeshes will return non-null.
| |
HasHistoryRecord |
Returns whether this object has a history record
| |
HasTextureMapping |
Returns true if this object has a texture mapping form any source (pluginId)
| |
Highlight |
Modifies the highlighting of the object.
| |
HighlightSubObject |
Highlights a sub-object.
| |
HistoryChildren |
Gets the ids of the child Rhino objects of this object.
| |
HistoryParents |
Gets the ids of the parent Rhino objects of this object.
| |
InVisualAnalysisMode |
Reports if any visual analysis mode is currently active for an object.
| |
InVisualAnalysisMode(VisualAnalysisMode) |
Reports if a visual analysis mode is currently active for an object.
| |
IsActiveInViewport |
Determine if this object is active in a particular viewport.
| |
IsHighlighted | Check highlight state. | |
IsMeshable |
Returns true if the object is capable of having a mesh of the specified type
| |
IsSelectable | Reports if an object can be selected. | |
IsSelectable(Boolean, Boolean, Boolean, Boolean) | Reports if an object can be selected. | |
IsSelected | Check selection state. | |
IsSubObjectHighlighted |
Determines if a sub-object is highlighted.
| |
IsSubObjectSelectable | Reports if a sub-object can be selected. | |
IsSubObjectSelected | Check sub-object selection state. | |
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) | |
LockId |
Locks the component Id property.
(Inherited from ModelComponent.) | |
LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) | |
LockName |
Locks the component Name property.
(Inherited from ModelComponent.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
Note that this is a runtime memory estimate and does not directly compare to the
amount of space take up by the object when saved to a file.
| |
MeshCount |
RhinoObjects can have several different types of meshes and
different numbers of meshes. A b-rep can have a render and
an analysis mesh on each face. A mesh object has a single
render mesh and no analysis mesh. Curve, point, and annotation
objects have no meshes.
| |
MeshObjects(IEnumerableRhinoObject, MeshingParameters, Mesh, ObjectAttributes) | Meshes Rhino objects. | |
MeshObjects(IEnumerableRhinoObject, MeshingParameters, Mesh, ObjectAttributes, Boolean) | Meshes Rhino objects. | |
MeshObjects(IEnumerableRhinoObject, MeshingParameters, Boolean, Mesh, ObjectAttributes) | Meshes Rhino objects. | |
MeshObjects(IEnumerableRhinoObject, MeshingParameters, Int32, Transform, Mesh, ObjectAttributes) | Meshes Rhino objects. | |
NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being constant. | |
ObjectFrame | ||
ObjectFrame(RhinoObjectObjectFrameFlags) | ||
OnAddToDocument |
This call informs an object it is about to be added to the list of
active objects in the document.
| |
OnDeleteFromDocument |
This call informs an object it is about to be deleted.
Some objects, like clipping planes, need to do a little extra cleanup
before they are deleted.
| |
OnDraw |
Called when Rhino wants to draw this object
| |
OnDuplicate |
Called when this a new instance of this object is created and copied from
an existing object
| |
OnPick |
Called to determine if this object or some sub-portion of this object should be
picked given a pick context.
| |
OnPicked |
Called when this object has been picked
| |
OnSelectionChanged |
Called when the selection state of this object has changed
| |
OnSpaceMorph |
Called when a space morph has been applied to the geometry.
Currently this only works for CustomMeshObject instances
| |
OnSwitchToNonConst |
Is called when a non-constant operation first occurs.
(Inherited from CommonObject.) | |
OnTransform |
Called when a transformation has been applied to the geometry
| |
RenderMeshes |
Returns a set of custom render primitives for this object.
| |
Select(Boolean) | Selects an object. | |
Select(Boolean, Boolean) | Selects an object. | |
Select(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Selects an object. | |
SelectSubObject(ComponentIndex, Boolean, Boolean) | Reports if an object can be selected. | |
SelectSubObject(ComponentIndex, Boolean, Boolean, Boolean) | Reports if an object can be selected. | |
SetCopyHistoryOnReplace |
If this object has a history record, the CopyOnReplace field is set
When an object is replaced in a document and the old object has a history record with
this field set, the history record is copied and attached to the new object.
That allows a descendant object to continue the history linkage after
it is edited.
| |
SetCustomRenderMeshParameter |
Set the named custom render mesh parameter value for this object.
| |
SetHistory |
For expert use only.
Sets the history record that describes how this object was created.
This information is used to update this object when Rhino history is enabled and an input object changes.
| |
SetObjectFrame(Plane) | ||
SetObjectFrame(Transform) | ||
SetRenderMeshParameters |
Sets the per-object meshing parameters for this object.
When set, this object will use these meshing parameters when generating a render mesh,
instead of those provided by the document.
| |
SetTextureMapping(Int32, TextureMapping) | ||
SetTextureMapping(Int32, TextureMapping, Transform) |
Sets texture mapping and mapping object transform for a channel
| |
ShortDescription |
Gets a localized short descriptive name of the object.
| |
ShortDescriptionWithClosedStatus |
Gets a localized short descriptive name of the object, along with it's open/closed status.
| |
SupportsRenderPrimitiveList(ViewportInfo, DisplayPipelineAttributes) | Obsolete.
Determines if custom render meshes will be built for a particular object.
| |
SupportsRenderPrimitiveList(ViewportInfo, Boolean) | Obsolete.
Determines if custom render meshes will be built for a particular object.
| |
ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) | |
ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) | |
TryGetGumballFrame |
If a Rhino object has been manipulated by Rhino's gumball, and the gumball is not in its default position,
then the object's repositioned gumball frame is returned.
| |
TryGetRenderPrimitiveBoundingBox(ViewportInfo, DisplayPipelineAttributes, BoundingBox) | Obsolete.
Get the bounding box for the custom render meshes associated with this
object.
| |
TryGetRenderPrimitiveBoundingBox(ViewportInfo, Boolean, BoundingBox) | Obsolete.
Get the bounding box for the custom render meshes associated with this
object.
| |
UnhighlightAllSubObjects |
Removes highlighting from all sub-objects.
| |
UnselectAllSubObjects |
Removes selection from all sub-objects.
|