Click or drag to resize

RhinoObjectGetRenderMeshesWithUpdatedTCs Method

Note: This API is now obsolete.

Gets the render meshes of some objects.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.3
Syntax
[ObsoleteAttribute("Does not support custom render meshes, per-face materials or delivery of the shared pointer meshes.  Prefer RhinoObject.RenderMeshes.")]
public static ObjRef[] GetRenderMeshesWithUpdatedTCs(
	IEnumerable<RhinoObject> rhinoObjects,
	bool okToCreate,
	bool returnAllObjects,
	bool skipHiddenObjects,
	bool updateMeshTCs
)

Parameters

rhinoObjects
Type: System.Collections.GenericIEnumerableRhinoObject
An array, a list, or any enumerable set of Rhino objects.
okToCreate
Type: SystemBoolean
true if the method is allowed to instantiate new meshes if they do not exist.
returnAllObjects
Type: SystemBoolean
true if all objects should be returned.
skipHiddenObjects
Type: SystemBoolean
true if if hidden objects should be ignored.
updateMeshTCs
Type: SystemBoolean
true if the TCs should be updated with a texture mapping.

Return Value

Type: ObjRef
An array of object references.
See Also