RhinoObjectRenderMeshes Method |
Returns a set of custom render primitives for this object.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax public RenderMeshes RenderMeshes(
MeshType mt,
ViewportInfo vp,
List<InstanceObject> ancestry,
ref RenderMeshProviderFlags flags,
PlugIn plugin,
DisplayPipelineAttributes attrs
)
Public Function RenderMeshes (
mt As MeshType,
vp As ViewportInfo,
ancestry As List(Of InstanceObject),
ByRef flags As RenderMeshProviderFlags,
plugin As PlugIn,
attrs As DisplayPipelineAttributes
) As RenderMeshes
Parameters
- mt
- Type: Rhino.GeometryMeshType
The mesh type requested (render or analysis). - vp
- Type: Rhino.DocObjectsViewportInfo
The viewport being rendered - ancestry
- Type: System.Collections.GenericListInstanceObject
The ancestry tree - only used for by-parent object properties assignments. - flags
- Type: Rhino.Render.CustomRenderMeshesRenderMeshProviderFlags
See MeshProvider.Flags - plugin
- Type: Rhino.PlugInsPlugIn
The requesting plug-in (typically the calling plugin) - attrs
- Type: Rhino.DisplayDisplayPipelineAttributes
Display attributes for the caller - null if this is a full rendering.
Return Value
Type:
RenderMeshes Returns a set of custom render primitives for this object
See Also