Click or drag to resize

RenderMeshes Class

RenderMeshes is a collection of geometry instances for a given ObjectId typically returned by the Custom Render primitive system. As each set of primitives is returned by the RenderMeshProviders in turn, the running hash is updated with new information about the primitive modifications that have been made along the way.
Inheritance Hierarchy
SystemObject
  Rhino.Render.CustomRenderMeshesRenderMeshes

Namespace:  Rhino.Render.CustomRenderMeshes
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderMeshes : IDisposable, 
	IEnumerable<Instance>, IEnumerable

The RenderMeshes type exposes the following members.

Constructors
  NameDescription
Public methodRenderMeshes
Create a new render primitives collection.
Top
Properties
  NameDescription
Public propertyDocument
The document with which this IRenderMeshes object is associated.
Public propertyHash
The running hash for these render meshes.
Public propertyInstanceCount
The number of instance objects in this collection.
Public propertyObjectId
The ObjectId with which this IRenderMeshes object is associated.
Top
Methods
  NameDescription
Public methodAddInstance
Adds a new instance to the render primitives collection.
Public methodDispose
Dispose this collection
Protected methodDispose(Boolean)
Dispose
Protected methodFinalize
Finalizer for this collection
(Overrides ObjectFinalize.)
Public methodGetEnumerator
Return an object to iterator over the instances in the collection
Public methodGetHashCode
Overrides default hash code function - just returns Hash
(Overrides ObjectGetHashCode.)
Top
See Also