Click or drag to resize

RenderMeshes Constructor

Create a new render primitives collection.

Namespace:  Rhino.Render.CustomRenderMeshes
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public RenderMeshes(
	RhinoDoc doc,
	Guid objectId,
	Guid renderMeshProviderId,
	uint runningHash
)

Parameters

doc
Type: RhinoRhinoDoc
The Rhino document with which this collection will be associated.
objectId
Type: SystemGuid
The ObjectId that this collection is for.
renderMeshProviderId
Type: SystemGuid
The RenderMeshProvider that created this collection - if this is the first in the stack, typically this will be ON_nil_uuid.
runningHash
Type: SystemUInt32
The running hash of this collection - each RenderMeshProvider will update the hash with its own modification hash.
See Also