Click or drag to resize

DisplayPipelineAttributes Class

Represents display pipeline settings, such as "show transparency" and "show grips".
Inheritance Hierarchy
SystemObject
  Rhino.DisplayDisplayPipelineAttributes

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class DisplayPipelineAttributes : IDisposable, 
	ISerializable

The DisplayPipelineAttributes type exposes the following members.

Constructors
  NameDescription
Protected methodDisplayPipelineAttributes
Initializes a new instance of the DisplayPipelineAttributes class
Top
Properties
  NameDescription
Public propertyAmbientLightingColor
Public propertyAxesSizePercentage
Size of axes as a percentage of the grid extents.
Public propertyBackMaterialDiffuseColor
Public propertyBackMaterialShine
Get or set the back material shine (0 to Rhino.DocObjects.MaxShine). You must call DisplayModeDescription.UpdateDisplayMode() to commit this change.
Public propertyBackMaterialTransparency
Get or set the back material transparency (0 to 100). You must call DisplayModeDescription.UpdateDisplayMode() to commit this change.
Public propertyBoundingBoxMode
Public propertyCastShadows
Cast shadows.
Public propertyClippingEdgeColor
Clipping edge color
Public propertyClippingEdgeColorUsage
Specifies how the color for the Edges is determined
Public propertyClippingEdgeThickness
Edge thickness in pixels.
Public propertyClippingFillColor
Clipping plane fill color
Public propertyClippingPlaneFillColorUsage
Specifies how the color for the clipping plane object fill is determined.
Public propertyClippingShadeColor
Clipping plane solid color
Public propertyClippingShadeColorUsage
Specifies how to shade the clipping plane
Public propertyClippingShadeSelectedPlane
Shades the selected clipping plane.
Public propertyClippingShadeTransparency
Specifies the clipping plane transparency percentage.
Public propertyClipSelectionHighlight
Clips the highlight wires. Shaded selections always clip.
Public propertyContextForDraw
Public propertyControlPolygonColor
Control polygon color
Public propertyControlPolygonGripSize
The control point size in pixels.
Public propertyControlPolygonHighlight
Highlights the segments of the control polygon on either side of the control points.
Public propertyControlPolygonShow
Shows the control polygon and only shows the control points.
Public propertyControlPolygonShowPoints
Shows the control points while the control polygon is displayed.
Public propertyControlPolygonShowSurface
Shows the object while the control polygon is displayed.
Public propertyControlPolygonStyle
PointStyle for the control polygon. Supported values are ControlPoint, RoundControlPoint, VariableDot, and RoundDot
Public propertyControlPolygonUseFixedSingleColor
Specifies a color for the control polygon.
Public propertyControlPolygonUseSolidLines
Use dotted / solid lines
Public propertyControlPolygonWireThickness
The width of the control polygon lines in pixels.
Public propertyCullBackfaces
Public propertyCurveColor
Color used for drawing curves
Public propertyCurveThickness
Pixel thickness for curves
Public propertyCurveThicknessScale
Scale thickness for curves
Public propertyCurveThicknessUsage
Use a pixel thickness (CurveThickness) or a scale thickness (CurveThicknessScale)
Public propertyCustomGroundPlaneAltitude
Height above the world XY plane in model units
Public propertyCustomGroundPlaneAutomaticAltitude
Turns on auto-elevation that moves Ground Plane to the lowest point of the objects in the model.
Public propertyCustomGroundPlaneOn
Turn the custom ground plane on or off
Public propertyCustomGroundPlaneShadowOnly
Makes the ground plane transparent, but allows shadows to still be cast on it.
Public propertyDisableConduits
Public propertyDisableTransparency
Public propertyDynamicDisplayUsage
Sets the appearance of objects in the display
Public propertyEnglishName
Public propertyFillMode
Get or set the frame buffer fill mode.
Public propertyFrontMaterialShine
Get or set the front material shine (0 to Rhino.DocObjects.MaxShine). You must call DisplayModeDescription.UpdateDisplayMode() to commit this change.
Public propertyFrontMaterialTransparency
Get or set the front material transparency (0 to 100). You must call DisplayModeDescription.UpdateDisplayMode() to commit this change.
Public propertyGhostLockedObjects
Set locked appearance
Public propertyGridPlaneColor
The color of the grid plane
Public propertyGridPlaneTransparency
Transparency of the grid plane, percentage (0-100)
Public propertyGridPlaneVisibility
Set when to show the grid plane
Public propertyGridTransparency
Transparency of the grid, percentage (0-100)
Public propertyHighlightSurfaces
Shades entire object with highlight color.
Public propertyId
Public propertyIgnoreHighlights
Public propertyLayersFollowLockUsage
Applies the settings for locked objects to locked layers.
Public propertyLightingScheme
Public propertyLocalName
Public propertyLockedColor
Locked Object Color
Public propertyLockedObjectsDrawBehindOthers
Locked object are drawn behind other objects
Public propertyLockedObjectTransparency
LockedObjectTransparency.
Public propertyLockedObjectUsage
Set asource of display attributes for locked objects
Public propertyMeshEdgeColor
Sets the mesh edge color
Public propertyMeshEdgeColorReduction
The darken percentage of the color
Public propertyMeshEdgeThickness
Mesh edge width in pixels
Public propertyMeshNakedEdgeColor
Sets the naked edge color
Public propertyMeshNakedEdgeColorReduction
The darken percentage of the color
Public propertyMeshNakedEdgeThickness
Naked mesh edge width in pixels.}
Public propertyMeshNonmanifoldEdgeColor
Sets the nonmanifold edge color
Public propertyMeshNonmanifoldEdgeColorReduction
The darken percentage of the color
Public propertyMeshNonmanifoldEdgeThickness
Non-manifold mesh edge width in pixels
Public propertyMeshSpecificAttributes
Public propertyMeshVertexSize
Mesh vertex size in pixels
Public propertyObjectColor
Public propertyPlaneUsesGridColor
If true, use the grid thin line color in App settings
Public propertyPointCloudRadius
Public propertyPointCloudStyle
Public propertyPointRadius
Public propertyPointStyle
Public propertyRealtimeDisplayId
Get the ID of the real-time display engine attached to the view. This will be Guid.Empty if no real-time display engine is in use. This can be the case for instance when starting a _Render session for a real-time viewport integration. That still would cause this ID to be Guid.Empty.
Public propertyRealtimeRenderPasses
Get or set the real-time passes amount
Public propertyShadeVertexColors
Shade using vertex colors.
Public propertyShadingEnabled
Draw shaded meshes and surfaces
Public propertyShadowBiasX
ShadowBiasX (Self shadowing artifacts) from 0 (dirty) to 50 (cleaner).
Public propertyShadowClippingRadius
Camera-based shadow clipping radius
Public propertyShadowColor
Public propertyShadowEdgeBlur
Set blurring from 0 (no blurring) to 16 (maximum blurring)
Public propertyShadowIntensity
Shadow intensity (percentage 0-100)
Public propertyShadowMemoryUsage
Value from 1 to 16384 indicating how much memory is to be allocated. Actual memory use is ShadowMemoryUsage*ShadowMemoryUsage*4.
Public propertyShadowsIgnoreUserDefinedClippingPlanes
If true, shadows ignore user-defined clipping planes
Public propertyShadowSoftEdgeQuality
Soft edge quality, from 0 (none/faster) to 12 (softer/slower)
Public propertyShadowsOn
Enable shadows
Public propertyShadowTransparencyTolerance
Transparency tolerance from 0 (never cast shadows) to 100 (always case shadows)
Public propertyShowAnnotations
Show annotations.
Public propertyShowClipIntersectionEdges
Show edges and hatches where clipping planes clip objects
Public propertyShowClipIntersectionSurfaces
Show fills where clipping planes clip solid objects
Public propertyShowClippingEdges
Shows the edges between the clipping plane and clipped objects.
Public propertyShowClippingFills
When a clipping plane intersects a 3-D object and the section is closed, the section is filled.
Public propertyShowClippingPlanes
Show clipping planes.
Public propertyShowCurves
Draw curves
Public propertyShowGrips
Public propertyShowIsoCurves
Draw surface ISO curves.
Public propertyShowLights
Show light widgets.
Public propertyShowMeshEdges
Display mesh edges on/off
Public propertyShowMeshNakedEdges
Display mesh naked edges on/off
Public propertyShowMeshNonmanifoldEdges
Display mesh manifold edges on/off
Public propertyShowPointClouds
Show point clouds.
Public propertyShowPoints
Show points.
Public propertyShowRealtimeRenderProgressBar
Get or set whether the display is used for preview rendering or not.
Public propertyShowSubDBoundary
Set visibility of SubD naked edges.
Public propertyShowSubDCreases
Set visibility of SubD creased edges.
Public propertyShowSubDEdges
Set visibility of SubD smooth edges.
Public propertyShowSubDNonmanifoldEdges
Turn on/off color differentiation of SubD symmetry children.
Public propertyShowSubDReflectionPlanePreview
Public propertyShowSurfaceEdge
Turn Surface Edge visibility on or off
Public propertyShowSurfaceEdges
Show surface edges.
Public propertyShowSurfaceNakedEdge
Turn Surface Naked Edge visibility on or off
Public propertyShowTangentEdges
Show tangent edges.
Public propertyShowTangentSeams
Show tangent seams.
Public propertyShowText
Show text.
Public propertySkylightShadowQuality
Skylight shadow quality, from 0 (lowest) to 8 (highest)
Public propertyStereoContext
Get or set the stereo render context.
Public propertySubDBoundaryApplyPattern
Apply pattern to the edge
Public propertySubDBoundaryColorReduction
Color reduction percentage
Public propertySubDBoundaryEdgeColor
Edge color
Public propertySubDBoundaryEdgeColorUsage
Edge color usage
Public propertySubDBoundaryEdgeThickness
Edge thickness (pixels).
Public propertySubDBoundaryThicknessScale
Edge thickness scale
Public propertySubDBoundaryThicknessUsage
Public propertySubDCreaseInteriorApplyPattern
Apply pattern to the edge
Public propertySubDCreaseInteriorColorReduction
Color reduction percentage
Public propertySubDCreaseInteriorEdgeColor
Edge color
Public propertySubDCreaseInteriorEdgeColorUsage
Edge color usage
Public propertySubDCreaseInteriorEdgeThickness
Edge thickness (pixels).
Public propertySubDCreaseInteriorThicknessScale
Edge thickness scale
Public propertySubDCreaseInteriorThicknessUsage
Public propertySubDNonManifoldApplyPattern
Apply pattern to the edge
Public propertySubDNonManifoldColorReduction
Color reduction percentage
Public propertySubDNonManifoldEdgeColor
Edge color
Public propertySubDNonManifoldEdgeColorUsage
Edge color usage
Public propertySubDNonManifoldEdgeThickness
Edge thickness (pixels).
Public propertySubDNonManifoldThicknessScale
Edge thickness scale
Public propertySubDNonManifoldThicknessUsage
Public propertySubDReflectionAxisLineColor
Reflection axis line color
Public propertySubDReflectionPlaneAxisLineOn
Apply Turnh on or off the reflection plane axis line
Public propertySubDReflectionPlaneColor
Reflection plane color
Public propertySubDReflectionPlaneColorReduction
SubD replection plane color reduction percentage
Public propertySubDReflectionPlaneColorUsage
SubD replection plane color use
Public propertySubDSmoothInteriorApplyPattern
Apply pattern to the edge
Public propertySubDSmoothInteriorColorReduction
Color reduction percentage
Public propertySubDSmoothInteriorEdgeColor
Edge color
Public propertySubDSmoothInteriorEdgeColorUsage
Edge color usage
Public propertySubDSmoothInteriorEdgeThickness
Edge thickness (pixels).
Public propertySubDSmoothInteriorThicknessScale
Edge thickness scale
Public propertySubDSmoothInteriorThicknessUsage
Public propertySubDThicknessUsage
Thickness usage, pixel thickness or a scale thickness
Public propertySurfaceEdgeApplyPattern
Turn pattern application on or off
Public propertySurfaceEdgeColor
Public propertySurfaceEdgeColorReduction
Public propertySurfaceEdgeColorUsage
Public propertySurfaceEdgeThickness
Thickness for surface edges
Public propertySurfaceEdgeThicknessScale
Public propertySurfaceIsoColorsUsed
Public propertySurfaceIsoShowForFlatFaces
Public propertySurfaceIsoSingleColor
Public propertySurfaceIsoThickness
Public propertySurfaceIsoThicknessUScale
Public propertySurfaceIsoThicknessUsed
Public propertySurfaceIsoThicknessVScale
Public propertySurfaceIsoThicknessWScale
Public propertySurfaceIsoUColor
Public propertySurfaceIsoUThickness
Public propertySurfaceIsoUVColor
Public propertySurfaceIsoVColor
Public propertySurfaceIsoVThickness
Public propertySurfaceNakedAdgeColorReduction
Public propertySurfaceNakedEdgeApplyPattern
Turn pattern application on or off
Public propertySurfaceNakedEdgeColor
Public propertySurfaceNakedEdgeColorUsage
Public propertySurfaceNakedEdgeThickness
Public propertySurfaceNakedEdgeThicknessScale
Public propertyUseAssignedObjectMaterial
Gets or sets whether objects ought to be drawn using their assigned rendering material.
Public propertyUseCustomObjectColor
Gets or sets whether objects ought to be drawn using a custom color.
Public propertyUseCustomObjectColorBackfaces
Gets or sets whether objects ought to be drawn using a custom color for back faces.
Public propertyUseCustomObjectMaterial
Gets or sets whether objects ought to be drawn using a custom material.
Public propertyUseCustomObjectMaterialBackfaces
Gets or sets whether objects ought to be drawn using a custom material on backfaces.
Public propertyUseLightColor
Draw lights using light color
Public propertyUseSectionStyles
When enabled, the appearances of clipping fills and edges are based on objects' section style properties.
Public propertyUseSingleCurveColor
Use a single color for drawing curves
Public propertyViewSpecificAttributes
Public propertyWorldAxesIconColorUsage
Public propertyXrayAllObjects
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the DisplayPipelineAttributes
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the DisplayPipelineAttributes and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetColorFadeEffect
Get the current color fade effect data.
Public methodGetDiagonalHatchEffect
Get the current diagonal hatch strength and width in pixels.
Public methodGetDitherTransparencyEffect
Get the current dither transparency amount.
Public methodGetFill
Get fill colors used for clearing the frame buffer
Public methodGetObjectData
Public methodGetSurfaceEdgeThicknessUsage
Helper function for setting the SurfaceEdgeThicknessFlags
Public methodGetSurfaceIsoApplyPattern
Public methodGetSurfaceIsoColorUsage
Helper function for getting SurfaceIsoColorsUsed and SurfaceSingleIsoColor
Public methodGetSurfaceIsoThicknessUsage
This is a helper function that combines getting IsoThicknessUsed and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodGetSurfaceNakedEdgeThicknessUsage
This is a helper function that combines getting SurfaceNakeEdgeUseNormalThickness and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodHasColorFadeEffect
Returns TRUE if there is a color fade effect enabled with a color fade effect amount larger than 0.0, FALSE otherwise.
Public methodHasDiagonalHatchEffect
Returns TRUE if there is a diagonal hatch effect enabled with a hatch strength larger than 0.0, FALSE otherwise.
Public methodHasDitherTransparencyEffect
Returns TRUE if there is a dither transparency effect enabled with a transparency amount larger than 0.0, FALSE otherwise.
Public methodSetColorFadeEffect
Set a color fade effect to make objects fade a given amount towards a given color.
Public methodSetDiagonalHatchEffect
Set a diagonal hatch effect to make objects render with diagonal hatch with a given strength and width in pixels. The effect works by brightening and darkening pixels in a diagonal pattern.
Public methodSetDitherTransparencyEffect
Set a dither transparency effect to make objects render with a given amount of transparency using a dither effect.
Public methodSetFill(Color)
Set fill mode to solid color and set the fill color
Public methodSetFill(Color, Color)
Set fill mode to two color and set the colors
Public methodSetFill(Color, Color, Color, Color)
Set the fill mode to four color gradient and set the colors
Public methodSetSurfaceEdgeThicknessUsage
Helper function for getting the SurfaceEdgeThicknessFlags
Public methodSetSurfaceIsoApplyPattern
Public methodSetSurfaceIsoColorUsage
Helper function for setting SurfaceIsoColorsUsed and SurfaceIsoSingleColor
Public methodSetSurfaceIsoThicknessUsage
This is a helper function that combines setting IsoThicknessUsed and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodSetSurfaceNakedEdgeThicknessUsage
This is a helper function that combines setting SurfaceNakeEdgeUseNormalThickness and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Top
See Also