Click or drag to resize

DisplayPipelineAttributes Methods

The DisplayPipelineAttributes type exposes the following members.

Methods
  NameDescription
Public methodDispose
Protected methodDispose(Boolean)
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetColorFadeEffect
Get the current color fade effect data.
Public methodGetDiagonalHatchEffect
Get the current diagonal hatch strength and width in pixels.
Public methodGetDitherTransparencyEffect
Get the current dither transparency amount.
Public methodGetFill
Get fill colors used for clearing the frame buffer
Public methodGetObjectData
Public methodGetSurfaceEdgeThicknessUsage
Helper function for setting the SurfaceEdgeThicknessFlags
Public methodGetSurfaceIsoApplyPattern
Public methodGetSurfaceIsoColorUsage
Helper function for getting SurfaceIsoColorsUsed and SurfaceSingleIsoColor
Public methodGetSurfaceIsoThicknessUsage
This is a helper function that combines getting IsoThicknessUsed and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodGetSurfaceNakedEdgeThicknessUsage
This is a helper function that combines getting SurfaceNakeEdgeUseNormalThickness and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodHasColorFadeEffect
Returns TRUE if there is a color fade effect enabled with a color fade effect amount larger than 0.0, FALSE otherwise.
Public methodHasDiagonalHatchEffect
Returns TRUE if there is a diagonal hatch effect enabled with a hatch strength larger than 0.0, FALSE otherwise.
Public methodHasDitherTransparencyEffect
Returns TRUE if there is a dither transparency effect enabled with a transparency amount larger than 0.0, FALSE otherwise.
Public methodSetColorFadeEffect
Set a color fade effect to make objects fade a given amount towards a given color.
Public methodSetDiagonalHatchEffect
Set a diagonal hatch effect to make objects render with diagonal hatch with a given strength and width in pixels. The effect works by brightening and darkening pixels in a diagonal pattern.
Public methodSetDitherTransparencyEffect
Set a dither transparency effect to make objects render with a given amount of transparency using a dither effect.
Public methodSetFill(Color)
Set fill mode to solid color and set the fill color
Public methodSetFill(Color, Color)
Set fill mode to two color and set the colors
Public methodSetFill(Color, Color, Color, Color)
Set the fill mode to four color gradient and set the colors
Public methodSetSurfaceEdgeThicknessUsage
Helper function for getting the SurfaceEdgeThicknessFlags
Public methodSetSurfaceIsoApplyPattern
Public methodSetSurfaceIsoColorUsage
Helper function for setting SurfaceIsoColorsUsed and SurfaceIsoSingleColor
Public methodSetSurfaceIsoThicknessUsage
This is a helper function that combines setting IsoThicknessUsed and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Public methodSetSurfaceNakedEdgeThicknessUsage
This is a helper function that combines setting SurfaceNakeEdgeUseNormalThickness and SurfaceNakedEdgeThicknessUsageFlags settings to correspond to the behavor of the Settings page.
Top
See Also