RhinoObjectSelect Method (Boolean, Boolean) |
Selects an object.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int Select(
bool on,
bool syncHighlight
)
Public Function Select (
on As Boolean,
syncHighlight As Boolean
) As Integer
Parameters
- on
- Type: SystemBoolean
The new selection state; true activates selection. - syncHighlight
- Type: SystemBoolean
If true, then the object is highlighted if it is selected
and not highlighted if is not selected.
Highlighting can be and stay out of sync, as its specification is independent.
Return Value
Type:
Int320: object is not selected.
1: object is selected.
2: object is selected persistently.
Remarks
Objects that are locked, hidden, or on locked or hidden layers
cannot be selected. If IsSelectableWithGripsOn() returns false,
then an that object is not selectable if it has grips turned on.
See Also