Click or drag to resize

RhinoObjectGetFillSurfaces Method (RhinoObject, IEnumerableClippingPlaneObject)

Return list of fill surfaces if any for object and clipping plane. Fills are trimmed by clipping planes that did not generate them.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.7
Syntax
public static Brep[] GetFillSurfaces(
	RhinoObject rhinoObject,
	IEnumerable<ClippingPlaneObject> clippingPlaneObjects
)

Parameters

rhinoObject
Type: Rhino.DocObjectsRhinoObject
Object to clip
clippingPlaneObjects
Type: System.Collections.GenericIEnumerableClippingPlaneObject
Enumeration of clipping plane objects

Return Value

Type: Brep
Array of Brep containing fully trimmed fills if there were any generated.
See Also