Click or drag to resize

SubD Methods

The SubD type exposes the following members.

Methods
  NameDescription
Public methodClearEvaluationCache
Clear all cached evaluation information (meshes, surface points, bounding boxes, ...) that depends on edge tags, vertex tags, and the location of vertex control points.
Public methodComponentFromComponentIndex
Returns a SubDComponent, either a SubDEdge, SubDFace, or SubDVertex, from a component index.
Public methodCopyEvaluationCache
Expert function that copies cached evaluations of component subdivision points and limit surface information from src to this. Typically this is done for performance critical situations like control point editing: - Copy a SubD to be modified (this does not copy the evaluation cache) - Copy the evaluation cache from the unmodified SubD - Modify the SubD copy - Update the surface mesh cache so that only the modified parts are recalculated - Display, meshing, bounding boxes on the modified SubD are now available
Public methodStatic memberCreateFromCylinder
Creates a SubD form of a cylinder.
Public methodStatic memberCreateFromLoft
Creates a SubD lofted through shape curves.
Public methodStatic memberCreateFromMesh(Mesh)
Create a new SubD from a mesh.
Public methodStatic memberCreateFromMesh(Mesh, SubDCreationOptions)
Create a new SubD from a mesh.
Public methodStatic memberCreateFromSurface
Create a SubD that approximates the surface. If the surface is a SubD friendly NURBS surface and withCorners is true, then the SubD and input surface will have the same geometry.
Public methodStatic memberCreateFromSweep(NurbsCurve, NurbsCurve, IEnumerableNurbsCurve, Boolean, Boolean)
Fits a SubD through a series of profile curves that define the SubD cross-sections and two curves that defines SubD edges.
Public methodStatic memberCreateFromSweep(NurbsCurve, IEnumerableNurbsCurve, Boolean, Boolean, Boolean, Vector3d)
Fits a SubD through a series of profile curves that define the SubD cross-sections and one curve that defines a SubD edge.
Public methodStatic memberCreateGlobeSphere
Creates a SubD sphere made from polar triangle fans and bands of quads. The result resembles a globe with triangle fans at the poles and the edges forming latitude parallels and longitude meridians.
Public methodStatic memberCreateIcosahedron
Creates a SubD sphere based on an icosohedron (20 triangular faces and 5 valent vertices). This is a goofy topology for a Catmull-Clark subdivision surface (all triangles, all vertices have 5 edges). You may want to consider using the much behaved result from CreateSubDQuadSphere(sphere, vertexLocation, 1) or even the result from CreateSubDGlobeSphere().
Public methodStatic memberCreateQuadSphere
Creates a SubD sphere made from quad faces.
Public methodStatic memberCreateTriSphere
Creates a SubD sphere made from triangular faces. This is a goofy topology for a Catmull-Clark subdivision surface (all triangles and all vertices have 5 or 6 edges). You may want to consider using the much behaved result from CreateSubDQuadSphere() or even the result from CreateSubDGlobeSphere().
Protected methodDispose(Boolean)
Deletes the underlying native pointer during a Dispose call or GC collection
(Overrides GeometryBaseDispose(Boolean).)
Public methodDuplicateEdgeCurves
Gets Nurbs form of all edges in this SubD, with clamped knots. NB: Does not update the SubD evaluation cache before getting the edges.
Public methodDuplicateEdgeCurves(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Gets Nurbs form of edges in this SubD. NB: Does not update the SubD evaluation cache before getting the edges.
Public methodFlip
Reverses the orientation of all SubD normals.
Public methodInterpolateSurfacePoints(Point3d)
Modifies the SubD so that the SubD vertex limit surface points are equal to surface_points[]
Public methodInterpolateSurfacePoints(UInt32, Point3d)
Modifies the SubD so that the SubD vertex limit surface points of the listed vertices are equal to surface_points[].
Public methodStatic memberJoinSubDs(IEnumerableSubD, Double, Boolean)
Joins an enumeration of SubDs to form as few as possible resulting SubDs. There may be more than one SubD in the result array.
Public methodStatic memberJoinSubDs(IEnumerableSubD, Double, Boolean, Boolean)
Joins an enumeration of SubDs to form as few as possible resulting SubDs. There may be more than one SubD in the result array.
Public methodMergeAllCoplanarFaces(Double)
Merges adjacent coplanar faces into single faces.
Public methodMergeAllCoplanarFaces(Double, Double)
Merges adjacent coplanar faces into single faces.
Protected methodNonConstOperation
Destroy cache handle
(Overrides GeometryBaseNonConstOperation.)
Public methodOffset
Makes a new SubD with vertices offset at distance in the direction of the control net vertex normals. Optionally, based on the value of solidify, adds the input SubD and a ribbon of faces along any naked edges.
Protected methodOnSwitchToNonConst
Called when this object switches from being considered "owned by the document" to being an independent instance.
(Overrides GeometryBaseOnSwitchToNonConst.)
Public methodPackFaces
Resets the SubD to the default face packing if adding creases or deleting faces breaks the quad grids. It does not change the topology or geometry of the SubD. SubD face packs always stop at creases.
Public methodSetVertexSurfacePoint
Set the location of a single vertex surface point. This function is not suitable for setting the locations of multiple vertex surface points that are topologically near to each other.
Public methodSubdivide
Apply the Catmull-Clark subdivision algorithm and save the results in this SubD.
Public methodSubdivide(IEnumerableInt32)
Apply the Catmull-Clark subdivision algorithm and save the results in this SubD.
Public methodSubdivide(Int32)
Apply the Catmull-Clark subdivision algorithm and save the results in this SubD.
Public methodSurfaceMeshCacheExists
Checks that a surface mesh evaluation cache exists, and that it has the required options. This cache is used by - SurfacePoint, - ToNurbsCurve(Boolean), and - CreateFromSubD(SubD, Int32).
Public methodToBrep
Create a Brep based on this SubD geometry, based on SubDToBrepOptions.Default options.
Public methodToBrep(SubDToBrepOptions)
Create a Brep based on this SubD geometry.
Public methodUpdateAllTagsAndSectorCoefficients
Updates vertex tag, edge tag, and edge coefficient values on the active level. After completing custom editing operations that modify the topology of the SubD control net or changing values of vertex or edge tags, the tag and sector coefficients information on nearby components in the edited areas need to be updated.
Public methodUpdateSurfaceMeshCache
Top
See Also