Click or drag to resize

SubDComponentFromComponentIndex Method

Returns a SubDComponent, either a SubDEdge, SubDFace, or SubDVertex, from a component index.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.6
Syntax
public SubDComponent ComponentFromComponentIndex(
	ComponentIndex componentIndex
)

Parameters

componentIndex
Type: Rhino.GeometryComponentIndex
The component index.

Return Value

Type: SubDComponent
The SubDComponent if successful, null otherwise.
See Also