Click or drag to resize

SubDSurfaceMeshCacheExists Method

Checks that a surface mesh evaluation cache exists, and that it has the required options. This cache is used by - SurfacePoint, - ToNurbsCurve(Boolean), and - CreateFromSubD(SubD, Int32).

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.9
Syntax
public bool SurfaceMeshCacheExists(
	bool bTextureCoordinatesExist,
	bool bCurvaturesExist,
	bool bColorsExist
)

Parameters

bTextureCoordinatesExist
Type: SystemBoolean
If True, the cache must contain texture coordinates information.
bCurvaturesExist
Type: SystemBoolean
If True, the cache must contain curvature information.
bColorsExist
Type: SystemBoolean
If True, the cache must contain color information.

Return Value

Type: Boolean
True if the cache exists on all face fragments and has the required options.
Remarks
This does not check that the cache is up to date, UpdateSurfaceMeshCache(Boolean).
See Also