PointObject Methods |
The PointObject type exposes the following members.
Name | Description | |
---|---|---|
DuplicatePointGeometry | ||
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
GetBoundingBox |
Called when Rhino wants the bounding box of this object. Viewpoert can be null.
GetDynamicTransform |
While an object is being dynamically transformed (dragged, rotated, ...),
the current transformation can be retrieved and used for creating
GetGrips |
Returns grips for this object If grips are enabled. If grips are not
GetGroupList |
Allocates an array of group indices of length GroupCount.
GetMaterial(Boolean) |
Gets material that this object uses based on it's attributes and the document
that the object is associated with. In the rare case that a document is not
GetMaterial(ComponentIndex) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
GetMaterial(ComponentIndex, Guid) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset
GetMaterial(ComponentIndex, Guid, ObjectAttributes) |
Get the Material associated with the sub object
identified by componentIndex if the component index is
set to ComponentIndex.Unset then the top level material
GetRenderMaterial(Boolean) |
Gets the RenderMaterial that this object uses based on it's attributes
and the document that the object is associated with. If there is no
RenderMaterial associated with this object then null is returned. If
null is returned you should call GetMaterial to get the material used
GetRenderMaterial(ComponentIndex) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
GetRenderMaterial(ComponentIndex, Guid) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
GetRenderMaterial(ComponentIndex, Guid, ObjectAttributes) |
Gets the RenderMaterial associated with this object if there is one. If
there is no RenderMaterial associated with this object then null is
returned. If null is returned you should call GetMaterial to get the
GetRenderMeshParameters |
Returns the meshing parameters that this object uses for generating render meshes.
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
Note that this is a runtime memory estimate and does not directly compare to the
MeshCount |
RhinoObjects can have several different types of meshes and
different numbers of meshes. A b-rep can have a render and
an analysis mesh on each face. A mesh object has a single
render mesh and no analysis mesh. Curve, point, and annotation
OnAddToDocument |
This call informs an object it is about to be added to the list of
OnDeleteFromDocument |
This call informs an object it is about to be deleted.
Some objects, like clipping planes, need to do a little extra cleanup
OnDuplicate |
Called when this a new instance of this object is created and copied from
OnPick |
Called to determine if this object or some sub-portion of this object should be
OnSpaceMorph |
Called when a space morph has been applied to the geometry.
SetCopyHistoryOnReplace |
If this object has a history record, the CopyOnReplace field is set
When an object is replaced in a document and the old object has a history record with
this field set, the history record is copied and attached to the new object.
That allows a descendant object to continue the history linkage after
SetHistory |
For expert use only.
Sets the history record that describes how this object was created.
SetRenderMeshParameters |
Sets the per-object meshing parameters for this object.
When set, this object will use these meshing parameters when generating a render mesh,
TryGetGumballFrame |
If a Rhino object has been manipulated by Rhino's gumball, and the gumball is not in its default position,
TryGetRenderPrimitiveBoundingBox(ViewportInfo, DisplayPipelineAttributes, BoundingBox) | Obsolete.
Get the bounding box for the custom render meshes associated with this
TryGetRenderPrimitiveBoundingBox(ViewportInfo, Boolean, BoundingBox) | Obsolete.
Get the bounding box for the custom render meshes associated with this