Click or drag to resize

BinaryArchiveReader Methods

The BinaryArchiveReader type exposes the following members.

Methods
  NameDescription
Public methodAtEnd
true if at end of a file
Public methodBeginRead3dmChunk(UInt32, Int64)
Begins reading a chunk that must be in the archive at this location.
Public methodBeginRead3dmChunk(UInt32, Int32, Int32)
Begins reading a chunk that must be in the archive at this location.
Public methodDump3dmChunk
Function for studying contents of a file. The primary use is as an aid to help dig through files that have been damaged (bad disks, transmission errors, etc.) If an error is found, a line that begins with the word "ERROR" is printed.
Public methodEnableCRCCalculation
Expert user function to control CRC calculation while reading and writing. Typically this is used when seeking around and reading/writing information in non-serial order.
Public methodEndRead3dmChunk
Calling this will skip rest of stuff in chunk if it was only partially read.
Public methodRead3dmChunkVersion
A chunk version is a single byte that encodes a major.minor version number. Useful when creating I/O code for 3dm chunks that may change in the future. Increment the minor version number if new information is added to the end of the chunk. Increment the major version if the format of the chunk changes in some other way.
Public methodRead3dmStartSection
Public methodReadBool
Reads a Boolean from the archive.
Public methodReadBoolArray
Reads an array of Boolean from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadBoundingBox
Reads a BoundingBox from the archive.
Public methodReadByte
Reads a Byte from the archive.
Public methodReadByteArray
Reads an array of Byte from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadColor
Reads a Color from the archive.
Public methodReadCompressedBuffer
Reads an array of compressed Byte information from the archive and uncompresses it.

An array is returned even if the input was another enumerable type.

Public methodReadDictionary
Reads a complete ArchivableDictionary from the archive.
Public methodReadDouble
Reads a Double from the archive.
Public methodReadDoubleArray
Reads an array of Double from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadFont
Reads a Font from the archive.
Public methodReadGeometry
Reads a GeometryBase-derived object from the archive.

The GeometryBase class is abstract.

Public methodReadGeometryArray
Public methodReadGuid
Reads a Guid from the archive.
Public methodReadGuidArray
Reads an array of Guid from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadInt
Reads a Int32 from the archive.
Public methodReadInt64
Reads a Int64 from the archive.
Public methodReadIntArray
Reads an array of Int32 from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadInterval
Reads a Interval from the archive.
Public methodReadLine
Reads a Line from the archive.
Public methodReadMeshingParameters
Reads a MeshingParameters from the archive.
Public methodReadObjRef
Reads a ObjRef from the archive
Public methodReadObjRefArray
Reads an array of Double from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadPlane
Reads a Plane from the archive.
Public methodReadPoint
Reads a Point from the archive.
Public methodReadPoint2d
Reads a Point2d from the archive.
Public methodReadPoint3d
Reads a Point3d from the archive.
Public methodReadPoint3f
Reads a Point3f from the archive.
Public methodReadPoint4d
Reads a Point4d from the archive.
Public methodReadPointF
Reads a PointF from the archive.
Public methodReadRay3d
Reads a Ray3d from the archive.
Public methodReadRectangle
Reads a Rectangle from the archive.
Public methodReadRectangleF
Reads a RectangleF from the archive.
Public methodReadRenderSettings
Reads a RenderSettings-derived object from the archive.
Public methodReadSByte
Reads a SByte from the archive.
Public methodReadSByteArray
Reads an array of SByte from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadShort
Reads a Int16 from the archive.
Public methodReadShortArray
Reads an array of Int16 from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadSingle
Reads a Single from the archive.
Public methodReadSingleArray
Reads an array of Single from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadSize
Reads a Size from the archive.
Public methodReadSizeF
Reads a SizeF from the archive.
Public methodReadString
Reads a String from the archive.
Public methodReadStringArray
Reads an array of String from the archive.

An array is returned even if the input was another enumerable type.

Public methodReadTransform
Reads a Transform from the archive.
Public methodReadUInt
Reads a UInt32 from the archive.
Public methodReadUShort
Reads a UInt16 from the archive.
Public methodReadUtf8String
Reads a String from the archive.
Public methodReadVector2d
Reads a Vector2d from the archive.
Public methodReadVector3d
Reads a Vector3d from the archive.
Public methodReadVector3f
Reads a Vector3f from the archive.
Public methodSeekFromCurrentPosition(Int64)
seek from current position ( like fseek( ,SEEK_CUR) )
Public methodSeekFromCurrentPosition(UInt64, Boolean)
seek from current position ( like fseek( ,SEEK_CUR) )
Public methodSeekFromStart
seek from start position ( like fseek( ,SEEK_SET) )
Top
See Also