Click or drag to resize

CustomDisplay Class

Provides some basic (indeed, very basic) mechanisms for drawing custom geometry in viewports.
Inheritance Hierarchy
SystemObject
  Rhino.DisplayCustomDisplay

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CustomDisplay : IDisposable

The CustomDisplay type exposes the following members.

Constructors
  NameDescription
Public methodCustomDisplay
Constructs a new CustomDisplay instance. You must call Dispose() when you are done with this instance, otherwise the display methods will never be switched off.
Top
Properties
  NameDescription
Public propertyClippingBox
Gets the clipping box of this CustomDisplay.
Public propertyEnabled
Gets or sets the Enabled state of this CustomDisplay instance. If you wish to terminate this CustomDisplay, place a call to Dispose() instead.
Public propertyIsDisposed
Gets a value indicating whether this CustomDisplay instance has been disposed. Once a CustomDisplay has been disposed, you can no longer use it.
Top
Methods
  NameDescription
Public methodAddArc(Arc)
Adds a new, black arc to the display list.
Public methodAddArc(Arc, Color)
Adds a new, colored arc to the display list.
Public methodAddArc(Arc, Color, Int32)
Adds a new, colored arc to the display list.
Public methodAddCircle(Circle)
Adds a new, black circle to the display list.
Public methodAddCircle(Circle, Color)
Adds a new, colored arc to the display list.
Public methodAddCircle(Circle, Color, Int32)
Adds a new, colored circle to the display list.
Public methodAddCurve(Curve)
Adds a new, black curve to the display list. The curve will be duplicated so changes to the original will not affect the display.
Public methodAddCurve(Curve, Color)
Adds a new, colored curve to the display list. The curve will be duplicated so changes to the original will not affect the display.
Public methodAddCurve(Curve, Color, Int32)
Adds a new, colored curve to the display list. The curve will be duplicated so changes to the original will not affect the display.
Public methodAddLine(Line)
Adds a new, black line to the display list.
Public methodAddLine(Line, Color)
Adds a new, colored line to the display list.
Public methodAddLine(Line, Color, Int32)
Adds a new, colored line to the display list.
Public methodAddPoint(Point3d)
Adds a new, black point to the display list.
Public methodAddPoint(Point3d, Color)
Adds a new colored point to the display list.
Public methodAddPoint(Point3d, Color, PointStyle, Int32)
Adds a new stylized point to the display list.
Public methodAddPoints(IEnumerablePoint3d)
Adds a collection of black points to the display list.
Public methodAddPoints(IEnumerablePoint3d, Color)
Adds a collection of colored points to the display list.
Public methodAddPoints(IEnumerablePoint3d, Color, PointStyle, Int32)
Adds a collection of stylized points to the display list.
Public methodAddPolygon
Adds a polygon to the drawing list. Polygons are not like Hatches, when you supply a concave polygon, the shading probably won't work.
Public methodAddText(Text3d, Color)
Adds a new 3D text object to the display list.
Public methodAddText(String, Plane, Double)
Adds a new, black 3D text object to the display list.
Public methodAddText(String, Plane, Double, Color)
Adds a new, colored 3D text object to the display list.
Public methodAddVector(Point3d, Vector3d)
Adds a new, black vector to the display list.
Public methodAddVector(Point3d, Vector3d, Color)
Adds a new, colored vector to the display list.
Public methodAddVector(Point3d, Vector3d, Color, Boolean)
Adds a new, colored vector to the display list.
Public methodClear
Clear the drawing lists.
Public methodDispose
Dispose this CustomDisplay instance. You must call this function in order to properly shut down the CustomDisplay.
Top
See Also