Click or drag to resize

ArchivableDictionarySet Method (String, GeometryBase)

Sets any class deriving from the GeometryBase base class.

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Set(
	string key,
	GeometryBase val
)

Parameters

key
Type: SystemString
A text key.
val
Type: Rhino.GeometryGeometryBase
A geometry object for that key.

Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary.

It is up to the user to clone this entry when appropriate. You can use Duplicate for this.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.Set(System.String,Rhino.Geometry.GeometryBase)"]

See Also