Click or drag to resize

ArchivableDictionarySet Method (String, IEnumerableObjRef)

Sets an array of ObjRef

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.8
Syntax
public bool Set(
	string key,
	IEnumerable<ObjRef> val
)

Parameters

key
Type: SystemString
A text key
val
Type: System.Collections.GenericIEnumerableObjRef
An object for that key

Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary.

It is up to the user to clone this entry when appropriate.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Collections.ArchivableDictionary.Set(System.String,System.Collections.Generic.IEnumerable{Rhino.DocObjects.ObjRef})"]

See Also