ArchivableDictionarySet Method (String, IEnumerableGeometryBase) |
Namespace:
Rhino.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax public bool Set(
string key,
IEnumerable<GeometryBase> val
)
Public Function Set (
key As String,
val As IEnumerable(Of GeometryBase)
) As Boolean
Parameters
- key
- Type: SystemString
A text key - val
- Type: System.Collections.GenericIEnumerableGeometryBase
An object for that key
Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary.
It is up to the user to clone this entry when appropriate.
Return Value
Type:
Booleantrue if successful, false otherwise.
See Also