MeshTextureCoordinateList Class |
Namespace: Rhino.Geometry.Collections
The MeshTextureCoordinateList type exposes the following members.
Name | Description | |
---|---|---|
Capacity |
Gets or sets the total number of texture coordinates the internal data structure can hold without resizing.
| |
Count |
Gets or sets the number of texture coordinates.
| |
Item |
Gets or sets the texture coordinate at the given index.
The index must be valid or an IndexOutOfRangeException will be thrown.
|
Name | Description | |
---|---|---|
Add(Point2f) |
Adds a new texture coordinate to the end of the Texture list.
| |
Add(Point3d) |
Adds a new texture coordinate to the end of the Texture list.
| |
Add(Double, Double) |
Adds a new texture coordinate to the end of the Texture list.
| |
Add(Single, Single) |
Adds a new texture coordinate to the end of the Texture list.
| |
AddRange |
Appends an array of texture coordinates.
| |
Clear |
Clears the Texture Coordinate list on the mesh.
| |
Destroy |
Releases all memory allocated to store texture coordinates. The list capacity will be 0 after this call.
Subsequent calls can add new items. | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetEnumerator |
Gets an enumerator that yields all texture coordinates in this collection.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
NormalizeTextureCoordinates |
Scales the texture coordinates so the texture domains are [0,1]
and eliminate any texture rotations.
| |
ReverseTextureCoordinates |
Reverses one coordinate direction of the texture coordinates.
The region of the bitmap the texture uses does not change. Either Us or Vs direction is flipped. | |
SetTextureCoordinate(Int32, Point2f) |
Sets or adds a texture coordinate to the Texture Coordinate List.
If [index] is less than [Count], the existing coordinate at [index] will be modified. If [index] equals [Count], a new coordinate is appended to the end of the coordinate list. If [index] is larger than [Count], the function will return false. | |
SetTextureCoordinate(Int32, Point3f) |
Sets or adds a texture coordinate to the Texture Coordinate List.
If [index] is less than [Count], the existing coordinate at [index] will be modified. If [index] equals [Count], a new coordinate is appended to the end of the coordinate list. If [index] is larger than [Count], the function will return false. | |
SetTextureCoordinate(Int32, Double, Double) |
Sets or adds a texture coordinate to the Texture Coordinate List.
If [index] is less than [Count], the existing coordinate at [index] will be modified. If [index] equals [Count], a new coordinate is appended to the end of the coordinate list. If [index] is larger than [Count], the function will return false. | |
SetTextureCoordinate(Int32, Single, Single) |
Sets or adds a texture coordinate to the Texture Coordinate List.
If [index] is less than [Count], the existing coordinate at [index] will be modified. If [index] equals [Count], a new coordinate is appended to the end of the coordinate list. If [index] is larger than [Count], the function will return false. | |
SetTextureCoordinates(Point2f) |
Sets all texture coordinates in one go.
| |
SetTextureCoordinates(TextureMapping) |
Set all texture coordinates based on a texture mapping function
| |
ToFloatArray |
Copies all vertices to a linear array of float in u,v order
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TransposeTextureCoordinates |
Transposes texture coordinates.
The region of the bitmap the texture uses does not change. All texture coordinates rows (Us) become columns (Vs), and vice versa. |